summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2023-07-01 22:28:59 +0200
committerPellegrino Prevete2023-07-01 22:28:59 +0200
commit92ae794487708f16f3a175a9a2c765b50a087cf4 (patch)
tree3ad90ec227996d6cebb3a228312f3e5b79f59430
downloadaur-92ae794487708f16f3a175a9a2c765b50a087cf4.tar.gz
initial build
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4069602df40
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = blueprint-compiler-health
+ pkgdesc = A markup language for GTK user interfaces
+ pkgver = 0.8.1
+ pkgrel = 1
+ url = https://jwestman.pages.gitlab.gnome.org/blueprint-compiler
+ arch = any
+ license = LGPL
+ makedepends = meson
+ depends = python-gobject
+ source = git+https://gitlab.gnome.org/jwestman/blueprint-compiler#commit=87cedc2c7e
+ sha256sums = SKIP
+
+pkgname = blueprint-compiler-health
+ provides = blueprint-compiler=0.8.1
+ conflicts = blueprint-compiler
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b39e5088f14b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Pellegrino Prevete (tallero) <pellegrinoprevete@gmail.com>
+
+_pkgname="blueprint-compiler"
+pkgname="blueprint-compiler-health"
+pkgver=0.8.1
+pkgrel=1
+_ns=jwestman
+pkgdesc='A markup language for GTK user interfaces'
+url="https://${_ns}.pages.gitlab.gnome.org/${_pkgname}"
+license=(LGPL)
+arch=(any)
+depends=(
+ python-gobject
+)
+makedepends=(
+ meson
+)
+_commit="87cedc2c7e"
+_repo_url="https://gitlab.gnome.org/${_ns}/${_pkgname}"
+source=(
+ "git+${_repo_url}#commit=${_commit}")
+sha256sums=(
+ 'SKIP')
+
+build() {
+ arch-meson "${_pkgname}" build
+ meson compile -C build
+}
+
+package() {
+ provides=("${_pkgname}=${pkgver}")
+ conflicts=("${_pkgname}")
+ meson install -C build --destdir "${pkgdir}"
+}