summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2023-07-02 01:50:49 +0200
committerPellegrino Prevete2023-07-02 01:50:49 +0200
commit9d225eea59f9eb0006cea8895c5f40e81726a764 (patch)
treeba35c567ed3808f4c66546b86043599673bc895a
parentc5bd11d4ff916e5e2509658239a89b7ae61c5ba3 (diff)
downloadaur-9d225eea59f9eb0006cea8895c5f40e81726a764.tar.gz
fix pkgver
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59ea5d5cafc1..bf528b74a8a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,7 @@ pkgbase = blueprint-compiler-health
license = LGPL
makedepends = meson
depends = python-gobject
- source = git+https://gitlab.gnome.org/jwestman/blueprint-compiler#commit=93f2a27e
+ source = https://gitlab.gnome.org/jwestman/blueprint-compiler/-/archive/93f2a27e35905420e70bfdb5c2f04d6af43b357d/blueprint-compiler-93f2a27e35905420e70bfdb5c2f04d6af43b357d.tar.gz
sha256sums = SKIP
pkgname = blueprint-compiler-health
diff --git a/PKGBUILD b/PKGBUILD
index daa8326eb115..f6cd2cee1615 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
_pkgname="blueprint-compiler"
pkgname="blueprint-compiler-health"
-_commit="93f2a27e"
+_commit="93f2a27e35905420e70bfdb5c2f04d6af43b357d"
_pkgver=0.8.1
-pkgver="${_pkgver}+${_commit}"
+pkgver="${_pkgver}+$(echo ${_commit} | cut -c 1-8)"
pkgrel=1
_ns=jwestman
pkgdesc='A markup language for GTK user interfaces'
@@ -15,17 +15,20 @@ depends=(
python-gobject
)
makedepends=(
+ # git
meson
)
-_commit="93f2a27e"
_repo_url="https://gitlab.gnome.org/${_ns}/${_pkgname}"
source=(
- "git+${_repo_url}#commit=${_commit}")
+ # "git+${_repo_url}#commit=${_commit}")
+ "${_repo_url}/-/archive/${_commit}/${_pkgname}-${_commit}.tar.gz"
+)
sha256sums=(
- 'SKIP')
+ 'SKIP'
+)
build() {
- arch-meson "${_pkgname}" build --prefix=/usr
+ arch-meson "${_pkgname}-${_commit}" build --prefix=/usr
meson compile -C build
}