summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2023-07-02 01:31:25 +0200
committerPellegrino Prevete2023-07-02 01:31:25 +0200
commit1a996864d95e160bea41c580e00bc2aa264cf16c (patch)
tree829976ac4a13c690758d7a2b36ffc44022a5e059
parent4e1fc440152f6cdd792437dec98ae930a1030b2b (diff)
downloadaur-1a996864d95e160bea41c580e00bc2aa264cf16c.tar.gz
initial commit
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4069602df40..6209073ece3d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,4 @@
-pkgbase = blueprint-compiler-health
+pkgbase = blueprint-compiler-health-git
pkgdesc = A markup language for GTK user interfaces
pkgver = 0.8.1
pkgrel = 1
@@ -10,6 +10,6 @@ pkgbase = blueprint-compiler-health
source = git+https://gitlab.gnome.org/jwestman/blueprint-compiler#commit=87cedc2c7e
sha256sums = SKIP
-pkgname = blueprint-compiler-health
+pkgname = blueprint-compiler-health-git
provides = blueprint-compiler=0.8.1
conflicts = blueprint-compiler
diff --git a/PKGBUILD b/PKGBUILD
index b39e5088f14b..3eff6cc1ed6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: Pellegrino Prevete (tallero) <pellegrinoprevete@gmail.com>
-_pkgname="blueprint-compiler"
-pkgname="blueprint-compiler-health"
+_pkg="blueprint-compiler"
+_pkgname="${_pkg}-health"
+pkgname="${_pkgname}-git"
pkgver=0.8.1
pkgrel=1
_ns=jwestman
pkgdesc='A markup language for GTK user interfaces'
-url="https://${_ns}.pages.gitlab.gnome.org/${_pkgname}"
+url="https://${_ns}.pages.gitlab.gnome.org/${_pkg}"
license=(LGPL)
arch=(any)
depends=(
@@ -16,19 +17,19 @@ makedepends=(
meson
)
_commit="87cedc2c7e"
-_repo_url="https://gitlab.gnome.org/${_ns}/${_pkgname}"
+_repo_url="https://gitlab.gnome.org/${_ns}/${_pkg}"
source=(
"git+${_repo_url}#commit=${_commit}")
sha256sums=(
'SKIP')
build() {
- arch-meson "${_pkgname}" build
+ arch-meson "${_pkg}" build --prefix=/usr
meson compile -C build
}
package() {
- provides=("${_pkgname}=${pkgver}")
- conflicts=("${_pkgname}")
+ provides=("${_pkg}=${pkgver}")
+ conflicts=("${_pkg}")
meson install -C build --destdir "${pkgdir}"
}