summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattias Andrée2015-06-12 13:50:13 +0200
committerMattias Andrée2015-06-12 13:50:13 +0200
commit530a1a260b34a4105758800ccabdc449d25f6def (patch)
treec0783bf9c754782581e26a19e824add2b352bc07
downloadaur-530a1a260b34a4105758800ccabdc449d25f6def.tar.gz
Initial import, version 1.90.3
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD30
-rw-r--r--blueshift.install20
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85716934737e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = blueshift
+ pkgdesc = An extensible and highly configurable alternative to redshift
+ pkgver = 1.90.3
+ pkgrel = 1
+ url = https://github.com/maandree/blueshift
+ install = blueshift.install
+ arch = i686
+ arch = x86_64
+ license = AGPL3
+ license = GPL3
+ license = custom:GFDL1.3
+ makedepends = cython
+ makedepends = gcc
+ makedepends = python3
+ makedepends = libxcb
+ makedepends = make
+ makedepends = coreutils
+ makedepends = sed
+ makedepends = zip
+ makedepends = texinfo
+ makedepends = auto-auto-complete
+ depends = python3
+ depends = solar-python
+ depends = argparser
+ depends = pylibgamma
+ depends = libxcb
+ optdepends = adjbacklight: for backlight adjustments without root requirements
+ optdepends = linux: for backlight support
+ optdepends = wget: for weather support, default command
+ source = https://github.com/maandree/blueshift/archive/1.90.3.tar.gz
+ sha256sums = 70bac54b6d8fad0bd2f88dff0d7dca94d3fd316541f23b3326dbbd70982c0698
+
+pkgname = blueshift
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34329305ec03
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=blueshift
+pkgver=1.90.3
+pkgrel=1
+pkgdesc="An extensible and highly configurable alternative to redshift"
+arch=(i686 x86_64)
+url="https://github.com/maandree/blueshift"
+license=('AGPL3' 'GPL3' 'custom:GFDL1.3')
+depends=(python3 solar-python argparser pylibgamma libxcb)
+optdepends=('adjbacklight: for backlight adjustments without root requirements'
+ 'linux: for backlight support'
+ 'wget: for weather support, default command')
+makedepends=(cython gcc python3 libxcb make coreutils sed zip texinfo auto-auto-complete)
+install=blueshift.install
+source=($url/archive/$pkgver.tar.gz)
+sha256sums=(70bac54b6d8fad0bd2f88dff0d7dca94d3fd316541f23b3326dbbd70982c0698)
+
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr LIBEXEC=/lib/blueshift
+}
+
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr LIBEXEC=/lib/blueshift install DESTDIR="$pkgdir"
+}
+
diff --git a/blueshift.install b/blueshift.install
new file mode 100644
index 000000000000..f7816a2a32ea
--- /dev/null
+++ b/blueshift.install
@@ -0,0 +1,20 @@
+_file="blueshift"
+
+infodir="usr/share/info"
+file="${_file}.info"
+
+
+post_install() {
+ [[ -x "usr/bin/install-info" ]] || return 0
+ install-info -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+pre_remove() {
+ [[ -x "usr/bin/install-info" ]] || return 0
+ install-info --delete -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
+}
+