summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2015-07-12 11:19:19 +0200
committeraksr2015-07-12 11:19:19 +0200
commitd6c1e2f19beee70db965f961b2186485bea9ac21 (patch)
tree1aee6078e9dc387d752137bb8b32790375d52f9a
downloadaur-d6c1e2f19beee70db965f961b2186485bea9ac21.tar.gz
Start.
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD35
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4439667219b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = blueshift-git
+ pkgdesc = An extensible and highly configurable alternative to redshift.
+ pkgver = 1.90.3.r1.g3f2d049
+ pkgrel = 1
+ url = https://github.com/maandree/blueshift
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = python
+ depends = pylibgamma
+ depends = solar-python
+ depends = argparser
+ depends = libxcb
+ depends = adjbacklight
+ depends = wget
+ depends = auto-auto-complete
+ source = blueshift-git::git+https://github.com/maandree/blueshift
+ md5sums = SKIP
+
+pkgname = blueshift-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19c72b936da0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=blueshift-git
+pkgver=1.90.3.r1.g3f2d049
+pkgrel=1
+epoch=
+pkgdesc="An extensible and highly configurable alternative to redshift."
+arch=('i686' 'x86_64')
+url="https://github.com/maandree/blueshift"
+license=('GPL')
+groups=()
+depends=('python' 'pylibgamma' 'solar-python' 'argparser' 'libxcb' 'adjbacklight' 'wget' 'auto-auto-complete')
+makedepends=('git')
+optdepends=()
+checkdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+changelog=
+install=
+source=("$pkgname::git+https://github.com/maandree/blueshift")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/" LIBEXEC="/lib/blueshift/" install
+}
+