summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaulo Matias2020-04-13 08:25:15 -0300
committerPaulo Matias2020-04-13 08:25:15 -0300
commit4dd45d87a6561f36a8a1631716182606d395e5ae (patch)
treeed0aea58628feecbede087a9d3beb6ae3edddcc8
parent3080045696fee2cb174af75162906dc6b10c461e (diff)
downloadaur-4dd45d87a6561f36a8a1631716182606d395e5ae.tar.gz
Some patches pushed upstream
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--archlinux.patch28
3 files changed, 4 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6f882670b95..750ab4f8d692 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bluespec-git
pkgdesc = Bluespec Compiler (BSC)
- pkgver = r285.9dfe8f5
+ pkgver = r287.d9e5b0f
pkgrel = 1
url = https://github.com/B-Lang-org/bsc
arch = x86_64
@@ -17,7 +17,7 @@ pkgbase = bluespec-git
source = git+https://github.com/b-lang-org/bsc.git
source = archlinux.patch
sha256sums = SKIP
- sha256sums = 32f1befc93b371c5a744cf01447c8386337641c2efae75090abea0a119e330aa
+ sha256sums = b7d08d9ff38728449566fbd5acbee942d4b781a7592f3ff777b4b0015593fd17
pkgname = bluespec-git
diff --git a/PKGBUILD b/PKGBUILD
index dcf0a93195e6..caebadf469da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Paulo Matias <matias@ufscar.br>
pkgname=bluespec-git
-pkgver=r285.9dfe8f5
+pkgver=r287.d9e5b0f
pkgrel=1
pkgdesc='Bluespec Compiler (BSC)'
arch=('x86_64')
@@ -13,7 +13,7 @@ makedepends=('git' 'gperf' 'ghc' 'xorg-server-xvfb')
source=("git+https://github.com/b-lang-org/bsc.git"
"archlinux.patch")
sha256sums=('SKIP'
- '32f1befc93b371c5a744cf01447c8386337641c2efae75090abea0a119e330aa')
+ 'b7d08d9ff38728449566fbd5acbee942d4b781a7592f3ff777b4b0015593fd17')
_prefix="/opt/bluespec"
pkgver() {
diff --git a/archlinux.patch b/archlinux.patch
index f51210dc63ba..ed0532158c15 100644
--- a/archlinux.patch
+++ b/archlinux.patch
@@ -20,31 +20,3 @@ index 5e38ec2..b832d80 100644
endif
# -----
-diff --git a/src/vendor/htcl/Makefile b/src/vendor/htcl/Makefile
-index a5deb63..ec51a6b 100644
---- a/src/vendor/htcl/Makefile
-+++ b/src/vendor/htcl/Makefile
-@@ -1,9 +1,9 @@
--CFLAGS += -Wall $(shell pkg-config --silence-errors --cflags-only-I tcl || echo -I/usr/include/tcl)
-+GHCFLAGS += -Wall $(shell pkg-config --silence-errors --cflags-only-I tcl || echo -I/usr/include/tcl)
- GHC ?= ghc
-
- # We use GHC to compile this, so it has the proper RTS includes
- %.o: %.c
-- $(GHC) $(CFLAGS) -c $<
-+ $(GHC) $(GHCFLAGS) -c $<
-
- libhtcl.a: haskell.o
- ar -r $@ $(filter %.o, $+)
-diff --git a/src/vendor/stp/src/sat/Makefile b/src/vendor/stp/src/sat/Makefile
-index 0d0937d..912f7b1 100644
---- a/src/vendor/stp/src/sat/Makefile
-+++ b/src/vendor/stp/src/sat/Makefile
-@@ -13,6 +13,7 @@ export COPTIMIZE=$(CFLAGS_M32) $(CFLAGS_FPIC) -O3
- core: $(LIB)
-
- # $(LIB) depends on */lib$(SUB)_release.a and will be rebuilt only if they have been updated
-+.NOTPARALLEL:
- $(LIB): core/libcore_release.a core_prop/libcore_prop_release.a simp/libsimp_release.a utils/libutils_release.a cryptominisat2/libminisat.a $(OBJS)
- $(RM) $@
- $(call arcat,$@,$(filter %.a,$^))