summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiuyang liu2020-02-05 02:50:55 +0000
committerJiuyang liu2020-02-05 02:50:55 +0000
commitd797bcf3ca1e25bc9a06e49ebe69f27bd00f591b (patch)
tree171ca502529f7db4957c4e95e51e73c79820408b
downloadaur-d797bcf3ca1e25bc9a06e49ebe69f27bd00f591b.tar.gz
TODO build failed
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e54914446f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = bluespec-git
+ pkgdesc = Bluespec Compiler (BSC)
+ pkgver = r3.cc623d8
+ pkgrel = 1
+ url = https://github.com/B-Lang-org/bsc
+ arch = x86_64
+ license = custom
+ makedepends = ghc
+ makedepends = haskell-regex-compat
+ makedepends = haskell-syb
+ makedepends = haskell-old-time
+ makedepends = fontconfig
+ makedepends = libxft
+ source = git+https://github.com/B-Lang-org/bsc.git
+ md5sums = SKIP
+
+pkgname = bluespec-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..897c0c43838f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jiuyang Liu <liujiuyang1994@gmail.com>
+
+pkgname=bluespec-git
+pkgver=r3.cc623d8
+pkgrel=1
+pkgdesc='Bluespec Compiler (BSC)'
+arch=('x86_64')
+url='https://github.com/B-Lang-org/bsc'
+license=('custom')
+depends=()
+makedepends=('ghc' 'haskell-regex-compat' 'haskell-syb' 'haskell-old-time' 'fontconfig' 'libxft')
+source=("git+https://github.com/B-Lang-org/bsc.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/bsc"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/bsc"
+ git submodule update --init --recursive
+}
+
+build(){
+ cd "$srcdir/bsc"
+ make GHC="ghc -dynamic"
+}
+
+package() {
+ cd "$srcdir/bsc"
+}
+