summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-11 11:24:41 +0800
committerzxp198210052024-03-11 11:24:41 +0800
commit996f36de37e7868c2b7dba70b735b55e946e4744 (patch)
tree4e060b6fb9ffb766bb38937d5452fbf272b7e04a
parentaf7019e51a726203c30668f735425ad76357ad4e (diff)
downloadaur-996f36de37e7868c2b7dba70b735b55e946e4744.tar.gz
update to 0.20.2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
-rw-r--r--bluestone.sh5
3 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cdf71caf498f..a2fd99846abd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bluestone
pkgdesc = A WYSIWYG Markdown editor, improve reading and editing experience.
- pkgver = 0.20.1
+ pkgver = 0.20.2
pkgrel = 1
url = https://github.com/1943time/bluestone
arch = any
@@ -12,9 +12,9 @@ pkgbase = bluestone
makedepends = git
depends = electron29
conflicts = bluestone
- source = bluestone.git::git+https://github.com/1943time/bluestone.git#tag=v0.20.1
+ source = bluestone.git::git+https://github.com/1943time/bluestone.git#tag=v0.20.2
source = bluestone.sh
sha256sums = SKIP
- sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = bluestone
diff --git a/PKGBUILD b/PKGBUILD
index dab39a836d63..26ab500ba0f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=bluestone
_pkgname=Bluestone
-pkgver=0.20.1
+pkgver=0.20.2
_electronversion=29
_nodeversion=18
pkgrel=1
@@ -25,7 +25,7 @@ source=(
"${pkgname}.sh"
)
sha256sums=('SKIP'
- '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
_ensure_local_nvm() {
export NVM_DIR="${srcdir}/.nvm"
source /usr/share/nvm/init-nvm.sh || [[ $? != 1 ]]
@@ -36,6 +36,7 @@ build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname}.sh"
_ensure_local_nvm
gendesk -q -f -n --categories="Utility" --name="${pkgname}" --exec="${pkgname} %U"
diff --git a/bluestone.sh b/bluestone.sh
index 86cb3dc6a9bf..7ddcaab8d734 100644
--- a/bluestone.sh
+++ b/bluestone.sh
@@ -2,6 +2,7 @@
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
@@ -9,7 +10,7 @@ export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file