summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-04-10 17:50:04 +0800
committerzxp198210052024-04-10 17:50:04 +0800
commit99c015ef49f2187e6af65489a6da40fdf72fdc89 (patch)
tree40f1b6be39acc6db0930b96aaea6fd6036a78993
parent8f1ee920f8eeea8474af830927a0dc3943d22bb6 (diff)
downloadaur-99c015ef49f2187e6af65489a6da40fdf72fdc89.tar.gz
update to 0.21.2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd81f6053806..3dc33eaa27c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bluestone
pkgdesc = A WYSIWYG Markdown editor, improve reading and editing experience.
- pkgver = 0.21.0
+ pkgver = 0.21.2
pkgrel = 1
url = https://github.com/1943time/bluestone
arch = any
@@ -12,9 +12,9 @@ pkgbase = bluestone
makedepends = git
depends = electron29
conflicts = bluestone
- source = bluestone.git::git+https://github.com/1943time/bluestone.git#tag=v0.21.0
+ source = bluestone.git::git+https://github.com/1943time/bluestone.git#tag=v0.21.2
source = bluestone.sh
- sha256sums = c7f97dce8b5da7821cf1a9bbf9c17b659ad639a27e8c48588e14f082bd5b7ab1
+ sha256sums = SKIP
sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = bluestone
diff --git a/PKGBUILD b/PKGBUILD
index 0497f1b58ac2..cfcbb0a69c1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=bluestone
_pkgname=Bluestone
-pkgver=0.21.0
+pkgver=0.21.2
_electronversion=29
_nodeversion=18
pkgrel=1
@@ -24,7 +24,7 @@ source=(
"${pkgname}.git::git+${url}.git#tag=v${pkgver}"
"${pkgname}.sh"
)
-sha256sums=('c7f97dce8b5da7821cf1a9bbf9c17b659ad639a27e8c48588e14f082bd5b7ab1'
+sha256sums=('SKIP'
'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
_ensure_local_nvm() {
export NVM_DIR="${srcdir}/.nvm"
@@ -48,14 +48,16 @@ build() {
export ELECTRONVERSION="${_electronversion}"
export npm_config_disturl=https://electronjs.org/headers
HOME="${srcdir}/.electron-gyp"
- if [ `curl -s ipinfo.io/country | grep CN | wc -l ` -ge 1 ];then
- echo 'registry="https://registry.npmmirror.com/"' >> .npmrc
- echo 'electron_mirror="https://registry.npmmirror.com/-/binary/electron/"' >> .npmrc
- echo 'electron_builder_binaries_mirror="https://registry.npmmirror.com/-/binary/electron-builder-binaries/"' >> .npmrc
- fi
pnpm config set store-dir "${srcdir}/.pnpm_store"
pnpm config set cache-dir "${srcdir}/.pnpm_cache"
pnpm config set link-workspace-packages true
+ if [ `curl -s ipinfo.io/country | grep CN | wc -l ` -ge 1 ];then
+ export npm_config_registry=https://registry.npmmirror.com
+ export npm_config_electron_mirror=https://registry.npmmirror.com/-/binary/electron/
+ export npm_config_electron_builder_binaries_mirror=https://registry.npmmirror.com/-/binary/electron-builder-binaries/
+ else
+ echo "Your network is OK."
+ fi
sed "s|--linux --arm64 --x64|--dir|g" -i package.json
pnpm install --no-frozen-lockfile
pnpm run build