summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-07-16 11:07:20 +0300
committerDimitris Kiziridis2020-07-16 11:07:20 +0300
commit3ef5f79ca9b389e7af9c680b7741a9d8880d2941 (patch)
treeff11c7e09129e5b1e572ce132ea7486aa03ef898
downloadaur-3ef5f79ca9b389e7af9c680b7741a9d8880d2941.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0011f444659
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = bluetooth-unlock
+ pkgdesc = Simple script to unlock your Linux based Computer using a Bluetooth device when nearby
+ pkgver = V1RC9
+ pkgrel = 1
+ url = https://github.com/LethalEthan/Bluetooth-Unlock
+ arch = any
+ license = MIT
+ depends = python-pybluez
+ depends = tar
+ source = bluetooth-unlock-V1RC9.tar.gz::https://github.com/LethalEthan/Bluetooth-Unlock/archive/BU-V1RC9.tar.gz
+ sha256sums = dbd86cfbc47ae77a8f1369902f893eea420f7ea69dc6a58c5a30f4d60489a568
+
+pkgname = bluetooth-unlock
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6e00bb1cd91
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=bluetooth-unlock
+pkgver=V1RC9
+pkgrel=1
+pkgdesc='Simple script to unlock your Linux based Computer using a Bluetooth device when nearby'
+arch=('any')
+url='https://github.com/LethalEthan/Bluetooth-Unlock'
+license=('MIT')
+depends=('python-pybluez'
+ 'tar')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/LethalEthan/Bluetooth-Unlock/archive/BU-${pkgver}.tar.gz")
+sha256sums=('dbd86cfbc47ae77a8f1369902f893eea420f7ea69dc6a58c5a30f4d60489a568')
+
+package() {
+ cd "Bluetooth-Unlock-BU-${pkgver}"
+ install -Dm755 Bluetooth-Unlock.py "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: \ No newline at end of file