summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOrhun Parmaksız2024-03-01 14:25:13 +0300
committerOrhun Parmaksız2024-03-01 14:25:13 +0300
commitdcbeeeb434c6c132b6034687a0a9cedda30620bd (patch)
treea4c2bc256f6f2a51552cf186529abc62691d6632
downloadaur-dcbeeeb434c6c132b6034687a0a9cedda30620bd.tar.gz
Initial upload: bluetui 0.2-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD39
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f73347d48a2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = bluetui
+ pkgdesc = TUI for managing bluetooth devices
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/pythops/bluetui
+ arch = x86_64
+ license = GPL3
+ makedepends = cargo
+ depends = gcc-libs
+ depends = dbus
+ source = bluetui-0.2.tar.gz::https://github.com/pythops/bluetui/archive/v0.2.tar.gz
+ sha512sums = 4b7c3707dd203e403faabe65fbb73061a9b708677d01f5f965d22e361415dc7a58ecb46d3100b28daf0fd5685e6b695359a110ab5c8a9b708d7e37dc530c4ecf
+
+pkgname = bluetui
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a4aaab1ce08
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
+
+pkgname=bluetui
+pkgver=0.2
+pkgrel=1
+pkgdesc="TUI for managing bluetooth devices"
+arch=('x86_64')
+url="https://github.com/pythops/bluetui"
+license=('GPL3')
+depends=('gcc-libs' 'dbus')
+makedepends=('cargo')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha512sums=('4b7c3707dd203e403faabe65fbb73061a9b708677d01f5f965d22e361415dc7a58ecb46d3100b28daf0fd5685e6b695359a110ab5c8a9b708d7e37dc530c4ecf')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --release --frozen
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm 755 "target/release/$pkgname" -t "$pkgdir/usr/bin"
+ install -Dm 644 Readme.md -t "$pkgdir/usr/share/doc/$pkgname"
+}