summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordarkhz2022-07-09 03:53:41 +0530
committerdarkhz2022-07-09 03:53:41 +0530
commit3a42e96e2d2ccd38594c9df4aa1c4a165bc797e1 (patch)
treeb19cd3b8db06e699f9dbe109091219075b290000
downloadaur-3a42e96e2d2ccd38594c9df4aa1c4a165bc797e1.tar.gz
bluetuith: Initial PKGBUILD
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD29
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea1204bb3df7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = bluetuith-bin
+ pkgdesc = A TUI based bluetooth manager
+ pkgver = 0.0.2
+ pkgrel = 1
+ url = https://github.com/darkhz/bluetuith
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = aarch64
+ arch = armv6h
+ arch = armv7h
+ license = MIT
+ depends = bluez
+ depends = dbus
+ provides = bluetuith
+ conflicts = bluetuith
+ source_x86_64 = https://github.com/darkhz/bluetuith/releases/download/v0.0.2/bluetuith_0.0.2_Linux_x86_64.tar.gz
+ sha256sums_x86_64 = ad37de002ba4a27ac151134385c5b6a2034a774d9735210016005ce38f71e8f2
+ sha256sums_i686 = d5f14ae80301779fdcc5f2b288a22414b29a7171664b1e54ec9e12fa996de029
+ source_arm = https://github.com/darkhz/bluetuith/releases/download/v0.0.2/bluetuith_0.0.2_Linux_armv5.tar.gz
+ sha256sums_arm = 87ab06d32c1d8ff53baacb1c1ba77ff00a002e1fc05b7286ee888c9d55d8281d
+ source_aarch64 = https://github.com/darkhz/bluetuith/releases/download/v0.0.2/bluetuith_0.0.2_Linux_arm64.tar.gz
+ sha256sums_aarch64 = 88a038590aaf7cc4264ffab28955d0db4896d76e0d7b121d879ee57b360fd1a9
+ source_armv6h = https://github.com/darkhz/bluetuith/releases/download/v0.0.2/bluetuith_0.0.2_Linux_armv6.tar.gz
+ sha256sums_armv6h = cc5aec73ab7eb907a0c8bd6df8f1edc06d183f5c25100bf9c26edca17b4e9c97
+ source_armv7h = https://github.com/darkhz/bluetuith/releases/download/v0.0.2/bluetuith_0.0.2_Linux_armv7.tar.gz
+ sha256sums_armv7h = 48a23be76f20b05d0438dd9eb0434c530744ef28d743d3e95f33bce1dfbca725
+
+pkgname = bluetuith-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5873c4c18226
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: darkhz <kmachanwenw at gmail dot com>
+pkgname=bluetuith-bin
+_pkgname=bluetuith
+pkgver=0.0.2
+pkgrel=1
+pkgdesc="A TUI based bluetooth manager"
+arch=('x86_64' 'i686' 'arm' 'aarch64' 'armv6h' 'armv7h')
+url="https://github.com/darkhz/bluetuith"
+license=('MIT')
+depends=('bluez' 'dbus')
+provides=('bluetuith')
+conflicts=('bluetuith')
+
+source_x86_64=("https://github.com/darkhz/${_pkgname}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_Linux_x86_64.tar.gz")
+source_arm=("https://github.com/darkhz/${_pkgname}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_Linux_armv5.tar.gz")
+source_aarch64=("https://github.com/darkhz/${_pkgname}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_Linux_arm64.tar.gz")
+source_armv6h=("https://github.com/darkhz/${_pkgname}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_Linux_armv6.tar.gz")
+source_armv7h=("https://github.com/darkhz/${_pkgname}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_Linux_armv7.tar.gz")
+
+sha256sums_x86_64=("ad37de002ba4a27ac151134385c5b6a2034a774d9735210016005ce38f71e8f2")
+sha256sums_i686=("d5f14ae80301779fdcc5f2b288a22414b29a7171664b1e54ec9e12fa996de029")
+sha256sums_arm=("87ab06d32c1d8ff53baacb1c1ba77ff00a002e1fc05b7286ee888c9d55d8281d")
+sha256sums_aarch64=("88a038590aaf7cc4264ffab28955d0db4896d76e0d7b121d879ee57b360fd1a9")
+sha256sums_armv6h=("cc5aec73ab7eb907a0c8bd6df8f1edc06d183f5c25100bf9c26edca17b4e9c97")
+sha256sums_armv7h=("48a23be76f20b05d0438dd9eb0434c530744ef28d743d3e95f33bce1dfbca725")
+
+package() {
+ install -Dm 755 "${_pkgname}" -t "${pkgdir}/usr/bin"
+}