summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2015-06-13 17:59:16 +0200
committerMuflone2015-06-13 17:59:16 +0200
commit2b193ea4951c4710a24aaf0ddaac04a1a4492636 (patch)
treee7d3213df698aef59dee352da0ec22e252311e60
downloadaur-2b193ea4951c4710a24aaf0ddaac04a1a4492636.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD36
-rw-r--r--bluewho-git.install14
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af007aa53f56
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = bluewho-git
+ pkgdesc = Information and notification of new discovered bluetooth devices
+ pkgver = 0.2.2.ge44b6b9
+ pkgrel = 1
+ url = http://url.muflone.com/bluewho
+ install = bluewho-git.install
+ arch = any
+ license = GPL2
+ depends = gtk3
+ depends = gobject-introspection
+ depends = python2-xdg
+ depends = python2-gobject
+ depends = python2-pybluez
+ depends = gtk-update-icon-cache
+ optdepends = libcanberra: to play notification sound using canberra-gtk-play
+ optdepends = alsa-utils: to play notification sound using aplay
+ optdepends = libpulse: to play notification sound using paplay
+ optdepends = mplayer: to play notification sound using mplayer
+ provides = bluewho
+ conflicts = bluewho
+ source = git+https://github.com/muflone/bluewho.git
+ md5sums = SKIP
+
+pkgname = bluewho-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b4e631eb27f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Muflone http://url.muflone.com/contacts
+
+pkgname=bluewho-git
+pkgver=0.2.2.ge44b6b9
+pkgrel=1
+pkgdesc="Information and notification of new discovered bluetooth devices"
+url="http://url.muflone.com/bluewho"
+arch=('any')
+license=('GPL2')
+depends=('gtk3' 'gobject-introspection' 'python2-xdg' 'python2-gobject' 'python2-pybluez' 'gtk-update-icon-cache')
+optdepends=('libcanberra: to play notification sound using canberra-gtk-play'
+ 'alsa-utils: to play notification sound using aplay'
+ 'libpulse: to play notification sound using paplay'
+ 'mplayer: to play notification sound using mplayer'
+ )
+provides=('bluewho')
+conflicts=('bluewho')
+source=("git+https://github.com/muflone/bluewho.git")
+md5sums=('SKIP')
+install="${pkgname}.install"
+
+pkgver() {
+ cd "${pkgname%-*}"
+ git describe --always | sed 's|-|.|g'
+}
+
+build() {
+ cd "${pkgname%-*}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${pkgname%-*}"
+ python2 setup.py install --optimize=1 --root "${pkgdir}"
+}
+
diff --git a/bluewho-git.install b/bluewho-git.install
new file mode 100644
index 000000000000..a02985b5a2db
--- /dev/null
+++ b/bluewho-git.install
@@ -0,0 +1,14 @@
+post_install() {
+ gtk-update-icon-cache -q /usr/share/icons/hicolor/
+ xdg-icon-resource forceupdate
+ xdg-desktop-menu forceupdate
+}
+
+post_update() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+