summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2019-09-30 11:46:10 -0600
committerBrian Bidulock2019-09-30 11:46:10 -0600
commit7029851039a140a8e102c639fdf76c11dbdc3260 (patch)
treed1667c32c7c6bde79aa8569f4bfdc02132f3590c
parentc8c36635e97ad2c30c4778605af5f23c3ceacd8a (diff)
downloadaur-7029851039a140a8e102c639fdf76c11dbdc3260.tar.gz
uppkg
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 31 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 074fc837c547..093900cc0678 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bluez-git
pkgdesc = Libraries and tools for the Bluetooth protocol stack
- pkgver = 5.50.r295.g9e6da22ed
+ pkgver = 5.51.r1.gf82256202
pkgrel = 1
epoch = 1
url = http://www.bluez.org/
@@ -11,13 +11,16 @@ pkgbase = bluez-git
depends = libical
depends = libdbus
depends = glib2
+ depends = alsa-lib
+ depends = ell
+ depends = json-c
optdepends = cups: CUPS backend
- provides = bluez=5.50
- provides = bluez-utils
- provides = bluez-libs
- provides = bluez-cups
- provides = bluez-hid2hci
- provides = bluez-plugins
+ provides = bluez=5.51-1
+ provides = bluez-utils=5.51-1
+ provides = bluez-libs=5.51-1
+ provides = bluez-cups=5.51-1
+ provides = bluez-hid2hci=5.51-1
+ provides = bluez-plugins=5.51-1
conflicts = bluez
conflicts = bluez-utils
conflicts = bluez-libs
@@ -28,7 +31,6 @@ pkgbase = bluez-git
conflicts = obexd-client
conflicts = obexd-server
backup = etc/bluetooth/main.conf
- backup = etc/dbus-1/system.d/bluetooth.conf
source = bluez-git::git://git.kernel.org/pub/scm/bluetooth/bluez.git
source = bluetooth.modprobe
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index aa51f985b43b..9207a85969af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Swift Geek
pkgname=bluez-git
_pkgname=bluez
-pkgver=5.50.r295.g9e6da22ed
+pkgver=5.51.r1.gf82256202
pkgrel=1
epoch=1
pkgdesc="Libraries and tools for the Bluetooth protocol stack"
@@ -10,7 +10,7 @@ pkgdesc="Libraries and tools for the Bluetooth protocol stack"
url="http://www.bluez.org/"
arch=('i686' 'x86_64')
license=('GPL2')
-depends=('libical' 'libdbus' 'glib2')
+depends=('libical' 'libdbus' 'glib2' 'alsa-lib' 'ell' 'json-c')
optdepends=('cups: CUPS backend')
makedepends=('git')
conflicts=($_pkgname
@@ -22,14 +22,13 @@ conflicts=($_pkgname
$_pkgname-hcidump
'obexd-client'
'obexd-server')
-provides=($_pkgname=${pkgver%%.r*}
- $_pkgname-utils
- $_pkgname-libs
- $_pkgname-cups
- $_pkgname-hid2hci
- $_pkgname-plugins)
-backup=('etc/bluetooth/main.conf'
- 'etc/dbus-1/system.d/bluetooth.conf')
+provides=($_pkgname=${pkgver%%.r*}-${pkgrel}
+ $_pkgname-utils=${pkgver%%.r*}-${pkgrel}
+ $_pkgname-libs=${pkgver%%.r*}-${pkgrel}
+ $_pkgname-cups=${pkgver%%.r*}-${pkgrel}
+ $_pkgname-hid2hci=${pkgver%%.r*}-${pkgrel}
+ $_pkgname-plugins=${pkgver%%.r*}-${pkgrel})
+backup=('etc/bluetooth/main.conf')
source=("$pkgname::git://git.kernel.org/pub/scm/bluetooth/bluez.git"
bluetooth.modprobe)
md5sums=('SKIP'
@@ -53,13 +52,25 @@ build() {
--sysconfdir=/etc \
--localstatedir=/var \
--libexecdir=/usr/lib \
+ --with-dbusconfdir=/usr/share \
+ --enable-external-ell \
+ --enable-btpclient \
+ --enable-midi \
--enable-sixaxis \
+ --enable-mesh \
--enable-experimental \
--enable-manpages \
--enable-library # this is deprecated
make
}
+check() {
+ cd $pkgname
+ # tests segfault and hang
+# make check || /bin/true # https://bugzilla.kernel.org/show_bug.cgi?id=196621
+}
+
+
package() {
cd $pkgname
make DESTDIR="${pkgdir}" install