summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2021-07-28 18:07:51 -0600
committerBrian Bidulock2021-07-28 18:07:51 -0600
commitf6573805626a8d7f8f3fefd8424910889a9d4822 (patch)
tree6ef52d81544f96f4195bdb0fc011059b3a1a935b
parent5be2121b1929e1c39c7313f72f8740ec0b79a712 (diff)
downloadaur-f6573805626a8d7f8f3fefd8424910889a9d4822.tar.gz
uppkg add tools patch
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD13
2 files changed, 17 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84076d6236fb..0d61bac5b057 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bluez-git
pkgdesc = Libraries and tools for the Bluetooth protocol stack
- pkgver = 5.58.r80.gd7c2a4cee
+ pkgver = 5.60.r17.gb497b5942
pkgrel = 1
epoch = 1
url = http://www.bluez.org/
@@ -17,12 +17,12 @@ pkgbase = bluez-git
depends = json-c
optdepends = cups: CUPS backend
provides = libbluetooth.so
- provides = bluez=5.58-1
- provides = bluez-utils=5.58-1
- provides = bluez-libs=5.58-1
- provides = bluez-cups=5.58-1
- provides = bluez-hid2hci=5.58-1
- provides = bluez-plugins=5.58-1
+ provides = bluez=5.60-1
+ provides = bluez-utils=5.60-1
+ provides = bluez-libs=5.60-1
+ provides = bluez-cups=5.60-1
+ provides = bluez-hid2hci=5.60-1
+ provides = bluez-plugins=5.60-1
conflicts = bluez
conflicts = bluez-utils
conflicts = bluez-libs
@@ -39,4 +39,3 @@ pkgbase = bluez-git
md5sums = 671c15e99d7154c2df987b71c5851b3d
pkgname = bluez-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 45d19c34724b..e87075f8c896 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Juan Diego Tascon
-# Maintainer: Swift Geek
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Juan Diego Tascon
+# Contributor: Swift Geek
pkgname=bluez-git
_pkgname=bluez
-pkgver=5.58.r80.gd7c2a4cee
+pkgver=5.60.r17.gb497b5942
pkgrel=1
epoch=1
pkgdesc="Libraries and tools for the Bluetooth protocol stack"
@@ -76,6 +77,12 @@ check() {
package() {
cd $pkgname
make DESTDIR="${pkgdir}" install
+ # add missing toosl FS#41132, FS#41687, FS#42716
+ for f in `find tools/ -type f -perm -755`; do
+ install -Dm755 "$f" "${pkgdir}/usr/bin/$(basename $f)"
+ done
install -Dm644 src/main.conf "${pkgdir}/etc/bluetooth/main.conf"
install -Dm644 ${srcdir}/bluetooth.modprobe "${pkgdir}/usr/lib/modprobe.d/bluetooth-usb.conf"
}
+
+# vim:set ts=2 sw=2 et: