summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2023-02-13 00:53:47 +0000
committerJoão Figueiredo2023-02-13 00:53:47 +0000
commitb356e33111de965438c08b913c357de61c1258e7 (patch)
tree2e082195557a574f590080f34a17d5ccc63d2e12
parent80c11ae88a84754c41bf87b47cc78fccfc193013 (diff)
downloadaur-b356e33111de965438c08b913c357de61c1258e7.tar.gz
Migrate to Qt6 (for real)
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 630eaca22eb6..5cfc3e9310a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,22 @@
pkgbase = bluez-qt-git
pkgdesc = Qt wrapper for Bluez 5 DBus API
- pkgver = 5.83.0_r659.ga9b57fe
+ pkgver = 5.240.0_r742.g6bffe17
pkgrel = 1
url = https://community.kde.org/Frameworks
arch = x86_64
- groups = kf5-git
+ groups = kf6-git
license = GPL2
makedepends = git
makedepends = extra-cmake-modules-git
makedepends = doxygen
- makedepends = qt5-tools
- makedepends = qt5-declarative
- depends = qt5-base
+ makedepends = qt6-tools
+ makedepends = qt6-declarative
+ depends = qt6-base
depends = bluez
- optdepends = qt5-declarative: QML bindings
+ optdepends = qt6-declarative: QML bindings
provides = bluez-qt
conflicts = bluez-qt
source = git+https://github.com/KDE/bluez-qt.git
sha256sums = SKIP
pkgname = bluez-qt-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 59797aac1973..7e9eea859936 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,29 +3,30 @@
# Contributor: Antonio Rojas <arojas@archlinux.org>
pkgname=bluez-qt-git
-pkgver=5.83.0_r659.ga9b57fe
+pkgver=5.240.0_r742.g6bffe17
pkgrel=1
pkgdesc='Qt wrapper for Bluez 5 DBus API'
arch=($CARCH)
url='https://community.kde.org/Frameworks'
license=(GPL2)
-depends=(qt5-base bluez)
-makedepends=(git extra-cmake-modules-git doxygen qt5-tools qt5-declarative)
+depends=(qt6-base bluez)
+makedepends=(git extra-cmake-modules-git doxygen qt6-tools qt6-declarative)
conflicts=(${pkgname%-git})
provides=(${pkgname%-git})
-optdepends=('qt5-declarative: QML bindings')
-groups=(kf5-git)
+optdepends=('qt6-declarative: QML bindings')
+groups=(kf6-git)
source=("git+https://github.com/KDE/${pkgname%-git}.git")
sha256sums=('SKIP')
pkgver() {
cd ${pkgname%-git}
- _ver="$(grep -m1 'set(KF5\?_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
+ _ver="$(grep -m1 'set(KF_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
echo "${_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}
build() {
cmake -B build -S ${pkgname%-git} \
+ -DQT_MAJOR_VERSION=6 \
-DUDEV_RULES_INSTALL_DIR=/usr/lib/udev/rules.d \
-DBUILD_TESTING=OFF \
-DBUILD_QCH=ON