summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2024-01-27 05:14:11 -0800
committerxiota2024-01-27 05:14:11 -0800
commitb3e7ec65152ce3208c993d822f7fe05da336d483 (patch)
treec3cf0d5003ae0269c877478e77f825750edf7574
downloadaur-b3e7ec65152ce3208c993d822f7fe05da336d483.tar.gz
5.72
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD71
3 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b25e32b5c889
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = bluez-tools-extra
+ pkgdesc = deprecated tools from bluez (hciconfig, hcitool, rfcomm)
+ pkgver = 5.72
+ pkgrel = 1
+ url = http://www.bluez.org/
+ arch = i686
+ arch = x86_64
+ license = GPL-2.0-or-later
+ depends = bluez-libs
+ provides = bluez-hciconfig
+ provides = bluez-hcitool
+ provides = bluez-rfcomm
+ conflicts = bluez-hciconfig
+ conflicts = bluez-hcitool
+ conflicts = bluez-rfcomm
+ conflicts = bluez-utils-compat
+ source = https://www.kernel.org/pub/linux/bluetooth/bluez-5.72.tar.xz
+ sha256sums = 499d7fa345a996c1bb650f5c6749e1d929111fa6ece0be0e98687fee6124536e
+
+pkgname = bluez-tools-extra
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6d327a9b5ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,71 @@
+# Maintainer:
+
+pkgname=bluez-tools-extra
+pkgver=5.72
+pkgrel=1
+pkgdesc="deprecated tools from bluez (hciconfig, hcitool, rfcomm)"
+url="http://www.bluez.org/"
+license=('GPL-2.0-or-later')
+arch=('i686' 'x86_64')
+
+depends=(
+ "bluez-libs"
+)
+
+provides=(
+ 'bluez-hciconfig'
+ 'bluez-hcitool'
+ 'bluez-rfcomm'
+)
+conflicts=(
+ 'bluez-hciconfig'
+ 'bluez-hcitool'
+ 'bluez-rfcomm'
+ 'bluez-utils-compat'
+)
+
+_pkgsrc="bluez-$pkgver"
+_pkgext="tar.xz"
+source=("https://www.kernel.org/pub/linux/bluetooth/$_pkgsrc.$_pkgext")
+sha256sums=('499d7fa345a996c1bb650f5c6749e1d929111fa6ece0be0e98687fee6124536e')
+
+build() {
+ cd "$_pkgsrc"
+
+ gcc $CFLAGS \
+ tools/hciconfig.c tools/parser/{csr,parser,lmp}.c src/textfile.c \
+ -lbluetooth -o tools/hciconfig \
+ $LDFLAGS \
+ -DVERSION=\"$pkgver\" \
+ -DSTORAGEDIR=\"/var/lib/bluetooth\" \
+ -I.
+
+ gcc $CFLAGS \
+ tools/hcitool.c src/oui.c \
+ -lbluetooth -o tools/hcitool \
+ $LDFLAGS \
+ -DVERSION=\"$pkgver\" \
+ -DSTORAGEDIR=\"/var/lib/bluetooth\" \
+ -I.
+
+ gcc $CFLAGS \
+ tools/rfcomm.c lib/bluetooth.c lib/hci.c \
+ -o tools/rfcomm \
+ $LDFLAGS \
+ -DVERSION=\"$pkgver\" \
+ -DSTORAGEDIR=\"/var/lib/bluetooth\" \
+ -I.
+}
+
+package() {
+ cd "$_pkgsrc/tools"
+
+ install -Dm755 hciconfig -t "$pkgdir/usr/bin"
+ install -Dm755 hciconfig.1 -t "$pkgdir/usr/share/man/man1"
+
+ install -Dm755 hcitool -t "$pkgdir/usr/bin"
+ install -Dm755 hcitool.1 -t "$pkgdir/usr/share/man/man1"
+
+ install -Dm755 rfcomm -t "$pkgdir/usr/bin"
+ install -Dm755 rfcomm.1 -t "$pkgdir/usr/share/man/man1"
+}