summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12022-02-24 02:16:45 +0800
committerChocobo12022-02-24 02:17:14 +0800
commit73736fcd061f969d78854e9406854381ba818b5b (patch)
tree880d0c707082ee7db990746cb68fcc1495b1439b
downloadaur-73736fcd061f969d78854e9406854381ba818b5b.tar.gz
newpkg: bluez-tools-git r127.gf653217-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD44
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d281f4e69a19
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = bluez-tools-git
+ pkgdesc = A set of tools to manage bluetooth devices
+ pkgver = r127.gf653217
+ pkgrel = 1
+ url = https://github.com/khvzak/bluez-tools
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = glibc
+ depends = bluez
+ provides = bluez-tools
+ conflicts = bluez-tools
+ source = git+https://github.com/khvzak/bluez-tools.git
+ sha256sums = SKIP
+
+pkgname = bluez-tools-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2178a496713
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=bluez-tools-git
+pkgver=r127.gf653217
+pkgrel=1
+pkgdesc="A set of tools to manage bluetooth devices"
+arch=('i686' 'x86_64')
+url="https://github.com/khvzak/bluez-tools"
+license=('GPL')
+depends=('glibc' 'bluez')
+makedepends=('git')
+provides=('bluez-tools')
+conflicts=('bluez-tools')
+source=("git+https://github.com/khvzak/bluez-tools.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "bluez-tools"
+
+ _rev=$(git rev-list --count --all)
+ _hash=$(git rev-parse --short HEAD)
+ printf "r%s.g%s" "$_rev" "$_hash"
+}
+
+build() {
+ cd "bluez-tools"
+
+ ./autogen.sh \
+ --prefix="/usr"
+ make
+}
+
+check() {
+ cd "bluez-tools"
+
+ make check
+}
+
+package() {
+ cd "bluez-tools"
+
+ make DESTDIR="$pkgdir" install
+}