summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenedikt Vollmerhaus2019-03-30 22:17:58 +0000
committerBenedikt Vollmerhaus2019-03-30 22:17:58 +0000
commit020f2e9efa45c6983ffb5d1b5c732079d359a553 (patch)
treead10458e81917997fc9976cf84bb94238bfec0d5
downloadaur-020f2e9efa45c6983ffb5d1b5c732079d359a553.tar.gz
Release version 1.1.1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4da35c5fe742
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = blurwal
+ pkgdesc = Smoothly blurs the wallpaper when windows are opened.
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://gitlab.com/BVollmerhaus/blurwal
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ optdepends = libnotify: for displaying status notifications
+ source = https://gitlab.com/BVollmerhaus/blurwal/-/archive/1.1.1/blurwal-1.1.1.tar.gz
+ sha256sums = 492fcfc820f1679440cf8aee56b0634aad1eedc0635280c037214aa53cff72be
+
+pkgname = blurwal
+ depends = imagemagick
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5601aea4da33
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Benedikt Vollmerhaus <aur[at]vollmerhaus[dot]org>
+
+pkgname=blurwal
+pkgver=1.1.1
+pkgrel=1
+pkgdesc='Smoothly blurs the wallpaper when windows are opened.'
+arch=('any')
+url="https://gitlab.com/BVollmerhaus/${pkgname}"
+license=('MIT')
+depends=('python')
+optdepends=('libnotify: for displaying status notifications')
+makedepends=('python-setuptools')
+source=("https://gitlab.com/BVollmerhaus/${pkgname}/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('492fcfc820f1679440cf8aee56b0634aad1eedc0635280c037214aa53cff72be')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+check() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py test
+}
+
+package() {
+ depends=('imagemagick')
+ cd "${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}