summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkleintux2022-08-24 08:49:20 +0200
committerkleintux2022-08-24 08:49:20 +0200
commitbb302531a2146667280034c1ac020927f9b8d4d0 (patch)
tree99c8180950646ed859479388e3e53becc2ade3ca
parent7aa760a2ca41f00963a81b27f0091de4b40f6858 (diff)
downloadaur-bb302531a2146667280034c1ac020927f9b8d4d0.tar.gz
adopted. updated to 0.6.0. changed to build from source.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD32
2 files changed, 29 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97598d4822ae..9b3dcac4ba95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = blush
- pkgdesc = Grep with colours
- pkgver = 0.5.3
+ pkgdesc = Grep with colours in go
+ pkgver = 0.6.0
pkgrel = 1
url = https://github.com/arsham/blush
arch = x86_64
+ arch = aarch64
license = MIT
+ makedepends = go
provides = blush
- conflicts = blush
- source = https://github.com/arsham/blush/releases/download/v0.5.3/blush_linux_v0.5.3.tar.gz
- sha256sums = 48a6af626b94e98a3de13b28cf1b0210b9f78b913a79df6e3013bc59019447d5
+ source = blush-0.6.0::https://github.com/arsham/blush/archive/refs/tags/v0.6.0.tar.gz
+ sha256sums = 6db6b033bb5d4c4ac350b36b82d79447d5b91509db3a5eceb72ecb9484495e54
pkgname = blush
-
diff --git a/PKGBUILD b/PKGBUILD
index eb9e1a6d24da..bb88f7882cba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,31 @@
-# Maintainer: Katie Wolfe <katie@dnaf.moe>
+# Maintainer: kleintux <reg-archlinux AT klein DOT tuxli DOT ch>
+# Contributor: Katie Wolfe <katie@dnaf.moe>
pkgname=blush
-pkgver=0.5.3
+pkgver=0.6.0
pkgrel=1
-pkgdesc='Grep with colours'
-arch=('x86_64')
+pkgdesc='Grep with colours in go'
+arch=('x86_64' 'aarch64')
url='https://github.com/arsham/blush'
license=('MIT')
-depends=()
+makedepends=('go')
provides=('blush')
-conflicts=('blush')
-source=("https://github.com/arsham/blush/releases/download/v${pkgver}/blush_linux_v${pkgver}.tar.gz")
-sha256sums=('48a6af626b94e98a3de13b28cf1b0210b9f78b913a79df6e3013bc59019447d5')
+source=("${pkgname}-${pkgver}::https://github.com/arsham/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('6db6b033bb5d4c4ac350b36b82d79447d5b91509db3a5eceb72ecb9484495e54')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o build/${pkgname}
+}
package() {
- install -Dm755 "${srcdir}/blush" "${pkgdir}/usr/bin/blush"
+ cd ${pkgname}-${pkgver}
+ install -Dm755 build/"${pkgname}" "${pkgdir}"/usr/bin/"${pkgname}"
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/"$pkgname"/README.md
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
+