summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Lubineau2011-04-01 23:26:58 +0200
committerAntoine Lubineau2011-04-01 23:26:58 +0200
commit2a8732ce3b827f93de63de287f66ed78a422ab58 (patch)
tree7ac5a54fb6bb7a4ae702afbb8479c8a4a475ee29
downloadaur-2a8732ce3b827f93de63de287f66ed78a422ab58.tar.gz
Fisrt version of bmdcapture
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore0
-rw-r--r--PKGBUILD26
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..626d5d33c59d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = bmdcapture
+ pkgdesc = BlackMagic Design DeckLink capture utility
+ pkgver = 0.9.6
+ pkgrel = 1
+ url = http://smorgasbork.com/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gcc-libs
+ depends = libgl
+ source = http://smorgasbork.com/bmdcapture/bmdcapture-0.9.6.tar.gz
+ md5sums = 4dec7596cfa6c9e7d835e312a6136c8d
+
+pkgname = bmdcapture
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..16c7c54b4efa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Antoine Lubineau <antoine@lubignon.info>
+
+pkgname=bmdcapture
+pkgver=0.9.6
+pkgrel=1
+pkgdesc="BlackMagic Design DeckLink capture utility"
+arch=('i686' 'x86_64')
+url="http://smorgasbork.com/"
+license=('GPL')
+depends=('gcc-libs' 'libgl')
+source=("http://smorgasbork.com/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('4dec7596cfa6c9e7d835e312a6136c8d')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ install -D -m0755 bmdcapture "$pkgdir/usr/bin/bmdcapture"
+}
+
+# vim:set ts=2 sw=2 et: