summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-08 20:27:33 +0200
committerStefan Husmann2015-06-08 20:27:33 +0200
commit8cd5dc83b816e025c9ad3fbeae13fd27e5133d73 (patch)
treea0a692af3bc64d9e5a7e27e8ff738e6226faf878
downloadaur-8cd5dc83b816e025c9ad3fbeae13fd27e5133d73.tar.gz
initial version
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..127f293092f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = bmpanel
+ pkgdesc = A modern, NETWM compliant, bitmap theme-based x11 panel.
+ pkgver = 0.9.27
+ pkgrel = 5
+ url = http://nsf.110mb.com/bmpanel/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = imlib2
+ depends = fontconfig
+ depends = libxrender
+ depends = libxcomposite
+ depends = ttf-dejavu
+ source = ftp://ftp.ru.debian.org/gentoo-distfiles/distfiles/bmpanel-0.9.27.tar.gz
+ md5sums = 23c2ecc89ec386a94b962a3d55403b24
+
+pkgname = bmpanel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..570e73b9d899
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: nsf <no.smile.face@gmail.com>
+
+pkgname=bmpanel
+pkgver=0.9.27
+pkgrel=5
+pkgdesc="A modern, NETWM compliant, bitmap theme-based x11 panel."
+arch=('i686' 'x86_64')
+url="http://nsf.110mb.com/bmpanel/"
+license=('custom')
+depends=('imlib2' 'fontconfig' 'libxrender' 'libxcomposite' 'ttf-dejavu')
+source=(ftp://ftp.ru.debian.org/gentoo-distfiles/distfiles/$pkgname-$pkgver.tar.gz)
+md5sums=('23c2ecc89ec386a94b962a3d55403b24')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+
+ ./configure --prefix=/usr
+ make
+}
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ DESTDIR=$pkgdir make install
+
+ install -D -m644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
+}