summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2019-02-05 22:18:50 -0500
committerTony Lambiris2019-02-05 22:18:50 -0500
commit1ada215c5e3caae53ae2d0de6b47c6a552706cbc (patch)
treea54d4ccd0bb83a48a05528f3130fdf9e1fdcb6d0
downloadaur-1ada215c5e3caae53ae2d0de6b47c6a552706cbc.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d84de7473f4b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = bmz-cursor-theme-git
+ pkgdesc = Mouse cursor for your X11 desktop. Inspiration was drawn from various sources, including DMZ and Breeze, but design manages to be quite unique.
+ pkgver = r3.a2eb059
+ pkgrel = 1
+ url = https://github.com/tonylambiris/BMZ-cursor
+ arch = any
+ license = GPL
+ makedepends = unzip
+ source = bmz-cursor-theme-git::git+https://github.com/tonylambiris/BMZ-cursor
+ sha256sums = SKIP
+
+pkgname = bmz-cursor-theme-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3e114373732b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+bmz-cursor-theme-git
+*pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6638ef538623
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Tony Lambiris <tony@criticalstack.com>
+pkgname=bmz-cursor-theme-git
+pkgver=r3.a2eb059
+pkgrel=1
+pkgdesc="Mouse cursor for your X11 desktop. Inspiration was drawn from various sources, including DMZ and Breeze, but design manages to be quite unique."
+arch=('any')
+url="https://github.com/tonylambiris/BMZ-cursor"
+license=('GPL')
+source=("${pkgname}::git+${url}")
+makedepends=('unzip')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ install -d -m755 $pkgdir/usr/share/icons/BMZ-cursor
+ cp -a * $pkgdir/usr/share/icons/BMZ-cursor
+}