summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryinflying2018-04-20 21:58:54 +0800
committeryinflying2018-04-20 21:58:54 +0800
commitd09613eb4a8350cb1df2d1ac722c9817b2b3bdb1 (patch)
tree2701e4e89fed19abbe91e49193209e1039aa1445
downloadaur-d09613eb4a8350cb1df2d1ac722c9817b2b3bdb1.tar.gz
init upload
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
-rw-r--r--bnc.desktop9
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d5eaa63e85e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = bnc-bin
+ pkgdesc = The BKG Ntrip Client(BNC) is an multi-stream client designed for real-time GNSS applications.
+ pkgver = 2.12.6
+ pkgrel = 1
+ url = http://www.rtklib.com/
+ arch = x86_64
+ groups = GNSS
+ license = GPL
+ depends = glibc
+ provides = bnc
+ source = https://igs.bkg.bund.de/root_ftp/NTRIP/software/bnc-2.12.6-debian8-64bit-static.zip
+ source = https://igs.bkg.bund.de/img/ntrip-logo.png
+ source = bnc.desktop
+ md5sums = 76f1ef2298ebbe11432575fa29d2e6f1
+ md5sums = cec39d8a485b402bccc2955f281db92d
+ md5sums = b14d15a36f293e8f64fe73b9618f7e69
+
+pkgname = bnc-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c9507ba18ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: yinflying <yinflying@foxmail.com>
+pkgname=bnc-bin
+pkgver=2.12.6
+pkgrel=1
+pkgdesc="The BKG Ntrip Client(BNC) is an multi-stream client designed for real-time GNSS applications."
+arch=('x86_64')
+url="http://www.rtklib.com/"
+license=('GPL')
+groups=('GNSS')
+depends=('glibc')
+#makedepends=() # 'bzr', 'git', 'mercurial' or 'subversion'
+provides=("bnc")
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=("https://igs.bkg.bund.de/root_ftp/NTRIP/software/bnc-${pkgver}-debian8-64bit-static.zip"
+ "https://igs.bkg.bund.de/img/ntrip-logo.png"
+ "bnc.desktop")
+md5sums=('76f1ef2298ebbe11432575fa29d2e6f1'
+ 'cec39d8a485b402bccc2955f281db92d'
+ 'b14d15a36f293e8f64fe73b9618f7e69')
+
+prepare() {
+ echo "good"
+}
+
+build() {
+ echo "good"
+}
+
+package() {
+ install -Dm755 "$srcdir/bnc-${pkgver}-debian8-64bit-static/bnc-${pkgver}-debian8-64bit-static" "$pkgdir/usr/bin/bnc"
+ install -Dm644 "${srcdir}/ntrip-logo.png" "${pkgdir}/usr/share/pixmaps/bnc.png"
+ install -Dm644 "${srcdir}/bnc.desktop" "${pkgdir}/usr/share/applications/bnc.desktop"
+}
diff --git a/bnc.desktop b/bnc.desktop
new file mode 100644
index 000000000000..bd47eb0d29a3
--- /dev/null
+++ b/bnc.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=BKG Ntrip Client
+GenericName=BNC
+Comment=an multi-stream client for real-time GNSS applications
+Exec=bnc
+Icon=/usr/share/pixmaps/bnc.png
+Terminal=false
+Type=Application
+Categories=Development;GNSS;