summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafal Mielniczuk2021-03-26 11:49:14 +0100
committerRafal Mielniczuk2021-03-26 11:49:45 +0100
commit8621f00f6b9a130431da6bcbd7c73b3b1ec27847 (patch)
tree74342da2ad674b466485a82cb6b5dcd9c57ae0bf
parenta4f23539ac2b1121f3cea64d6f98afc432453404 (diff)
downloadaur-8621f00f6b9a130431da6bcbd7c73b3b1ec27847.tar.gz
Fix build issue
https://sourceforge.net/p/bochs/bugs/1430/
-rw-r--r--PKGBUILD10
-rw-r--r--fix-build.patch13
2 files changed, 20 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 075fd7c7e724..ae8c2d62bbf1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Kevin Piche <kevin@archlinux.org>
pkgname=bochs-svn
-pkgver=2.6.11.r13903
+pkgver=2.6.11.r14201
pkgrel=1
pkgdesc="A portable x86 PC emulation software package, including GUI debugger (SVN Snapshot)"
arch=('x86_64')
@@ -22,6 +22,12 @@ pkgver() {
printf "%s.r%s" "$rel" "${ver//[[:alpha:]]}"
}
+prepare() {
+ cd "$srcdir/$pkgname"
+
+ patch -p0 < ../../fix-build.patch # https://sourceforge.net/p/bochs/bugs/1430/
+}
+
build() {
cd "$srcdir/$pkgname"
@@ -51,8 +57,6 @@ build() {
#--enable-all-optimizations
#--enable-plugins
- sed -i 's/BX_NETMOD_FBSD 1/BX_NETMOD_FBSD 0/g' config.h
-
make -j 1
}
diff --git a/fix-build.patch b/fix-build.patch
new file mode 100644
index 000000000000..82685e977a90
--- /dev/null
+++ b/fix-build.patch
@@ -0,0 +1,13 @@
+Index: iodev/pcidev.cc
+===================================================================
+--- iodev/pcidev.cc (revision 14201)
++++ iodev/pcidev.cc (working copy)
+@@ -242,7 +242,7 @@
+ // Check if the device is disabled or not configured
+ if (SIM->get_param_num(BXPN_PCIDEV_VENDOR)->get() == 0xffff) {
+ BX_INFO(("Host PCI device mapping disabled"));
+- BX_UNREGISTER_DEVICE_DEVMODEL("pcidev");
++ BX_UNREGISTER_DEVICE_DEVMODEL("pcidev", (int)PLUGTYPE_OPTIONAL);
+ return;
+ }
+