summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus2020-11-28 20:20:01 +0100
committerMarkus2020-11-28 20:20:01 +0100
commit5f405804afa8aedabdb8eee213bc87c20ff5612d (patch)
tree418cc4aa76baaa16b9c26e1ea424fb66a82ed291
downloadaur-5f405804afa8aedabdb8eee213bc87c20ff5612d.tar.gz
Intial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..373deaf0e976
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = boilr
+ pkgdesc = A CLI tool for creating and using templates for common actions
+ pkgver = 0.4.5
+ pkgrel = 1
+ url = https://github.com/Ilyes512/boilr
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = Apache
+ makedepends = go
+ source = https://github.com/Ilyes512/boilr/archive/0.4.5.tar.gz
+ sha512sums = fde934c2fab5ad06b1f02abb43423ffeb780cf1002a7348d08bf6d59a84cb4d7e460efa8cbe2261662e4d55cecb6fb396b36e1060afb9eda2568f2f1ad20d543
+
+pkgname = boilr
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b3b9126dd5ec
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.pkg.tar*
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6d06843f03a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Markus Richter <mqus at disroot dot org>
+
+pkgname=boilr
+pkgver=0.4.5
+pkgrel=1
+
+pkgdesc="A CLI tool for creating and using templates for common actions"
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
+url="https://github.com/Ilyes512/boilr"
+license=('Apache')
+depends=()
+optdepends=()
+makedepends=('go')
+source=("https://github.com/Ilyes512/$pkgname/archive/$pkgver.tar.gz")
+sha512sums=('fde934c2fab5ad06b1f02abb43423ffeb780cf1002a7348d08bf6d59a84cb4d7e460efa8cbe2261662e4d55cecb6fb396b36e1060afb9eda2568f2f1ad20d543')
+
+
+build() {
+ #build drone-runner-docker
+ cd "$srcdir/$pkgname-$pkgver"
+
+ go build \
+ -trimpath \
+ -buildmode=pie \
+ -mod=readonly \
+ -modcacherw \
+ -tags "nolimit" \
+ -gcflags "all=-trimpath=${PWD}" \
+ -ldflags "-linkmode external -extldflags \"${LDFLAGS}\""
+}
+
+package() {
+ # copy binary
+ install -D -m 0755 "$srcdir/$pkgname-$pkgver/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}