summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArtem Vorotnikov2016-12-15 07:16:06 +0300
committerArtem Vorotnikov2016-12-31 02:43:51 +0300
commit651cb030a255966cc90181ff75f2276340524299 (patch)
tree4cfe32492a138c7f8e7d5a12cbb3813f57c2c33c
downloadaur-651cb030a255966cc90181ff75f2276340524299.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore0
-rw-r--r--PKGBUILD28
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e04e17e2fcda
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Fri Dec 30 23:43:33 UTC 2016
+pkgbase = boinc-app-api
+ pkgdesc = API for communication with BOINC applcations.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/boinc-next/boinc-app-api
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ options = !staticlibs
+ source = git+https://github.com/boinc-next/boinc-app-api#tag=1.0
+ sha256sums = SKIP
+
+pkgname = boinc-app-api
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a43a73598b32
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+_username=boinc-next
+_reponame=boinc-app-api
+_pkgbase=boinc-app-api
+pkgname=${_pkgbase}
+pkgdesc="API for communication with BOINC applcations."
+pkgver=1.0
+pkgrel=1
+arch=('i686' 'x86_64')
+url="https://github.com/$_username/${_reponame/}"
+license=('LGPL')
+options=('!staticlibs')
+_ref="#tag=${pkgver}"
+source=("git+https://github.com/${_username}/${_reponame}${_ref}")
+sha256sums=('SKIP')
+
+build() {
+ cd ${srcdir}/${_reponame}
+
+ autoreconf -i
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${_reponame}
+
+ make DESTDIR="${pkgdir}" install
+}