summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArtem Vorotnikov2016-06-22 12:16:57 +0300
committerArtem Vorotnikov2016-06-22 12:16:57 +0300
commit0c6a3088218ecfdaa485884051592589e6d36767 (patch)
tree368b2183f0e38233895e4358a37261d6d4dc0e52
downloadaur-0c6a3088218ecfdaa485884051592589e6d36767.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..872946bf488b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Jun 22 09:16:49 UTC 2016
+pkgbase = boinc-gobject-git
+ pkgdesc = GObject-based API for BOINC client
+ pkgver = r1
+ pkgrel = 1
+ url = https://github.com/skybon/boinc-gobject
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = gobject-introspection
+ makedepends = vala
+ depends = glib2
+ depends = geoip
+ source = git+https://github.com/skybon/boinc-gobject.git
+ sha256sums = SKIP
+
+pkgname = boinc-gobject-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3003675ce150
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id$
+# Maintainer: Artem Vorotnikov <artem@vorotnikov.me>
+
+_pkgname=boinc-gobject
+pkgname=$_pkgname-git
+pkgver=r1
+pkgrel=1
+pkgdesc="GObject-based API for BOINC client"
+arch=('i686' 'x86_64')
+license=('LGPL')
+makedepends=('gobject-introspection' 'vala')
+depends=('glib2' 'geoip')
+url="https://github.com/skybon/boinc-gobject"
+source=('git+https://github.com/skybon/boinc-gobject.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ autoreconf --install
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="$pkgdir" install
+}