summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2016-11-13 00:35:15 +0100
committeranthraxx2016-11-13 00:35:15 +0100
commite05e425bc145f809ce2b0f864ae067acd6a39972 (patch)
treeb1257d1af982f54334db50ed372b3b549d17e15b
parente4236e12f6ab0e0d3b5ebc1e2c7cc74d2e370987 (diff)
downloadaur-e05e425bc145f809ce2b0f864ae067acd6a39972.tar.gz
upgpkg: bokken 1.8-3 (siwtch upstream + radare patch)
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD27
-rw-r--r--fix-new-radare.patch16
3 files changed, 37 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3bc67e7e99e5..7098d49aa9ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
pkgbase = bokken
pkgdesc = GUI for radare2 and pyew
pkgver = 1.8
- pkgrel = 2
+ pkgrel = 3
url = http://inguma.eu/projects/bokken
arch = any
license = GPL2
+ makedepends = mercurial
depends = pygtk
depends = pygtksourceview2
depends = python2-pillow
depends = graphviz
depends = radare2-bindings
- source = bokken-1.8.tar.gz::https://inguma.eu/attachments/download/212/bokken-1.8.tar.gz
- sha512sums = 4fc34c054b018bdf2012024827d909420f4384d3de32196b319299794a9e7ccf0d1ce22987bad5526af077fe2486b0b3d89ce62ef762c3c84dee58cb32fa09d0
+ source = bokken-1.8.tar.gz::https://bitbucket.org/inguma/bokken/get/1.8.tar.gz
+ source = fix-new-radare.patch
+ sha512sums = 1bec1c908bbfc5bf3dad121d98fc135a2b0ab9753077df113c7a5ca4059d3c7b86715ba2bd017fd1fa55e504e41eee4f22f76d551be4852371975ae45d3141f2
+ sha512sums = 478de59f170cf5d28ab0dbe16cf9cb1d472d40de3abbe049d9577319b2123b514cd08320213a36fa2ee441add680aa56fdfc721a26ee786ed59f1d12cc1825b9
pkgname = bokken
diff --git a/PKGBUILD b/PKGBUILD
index 625d0f4136bb..a931941daade 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,21 @@
pkgname=bokken
pkgver=1.8
-pkgrel=2
-pkgdesc="GUI for radare2 and pyew"
-url="http://inguma.eu/projects/bokken"
+pkgrel=3
+pkgdesc='GUI for radare2 and pyew'
+url='http://inguma.eu/projects/bokken'
arch=('any')
license=('GPL2')
depends=('pygtk' 'pygtksourceview2' 'python2-pillow' 'graphviz' 'radare2-bindings')
-source=(${pkgname}-${pkgver}.tar.gz::https://inguma.eu/attachments/download/212/${pkgname}-${pkgver}.tar.gz)
-sha512sums=('4fc34c054b018bdf2012024827d909420f4384d3de32196b319299794a9e7ccf0d1ce22987bad5526af077fe2486b0b3d89ce62ef762c3c84dee58cb32fa09d0')
+makedepends=('mercurial')
+source=(${pkgname}-${pkgver}.tar.gz::https://bitbucket.org/inguma/bokken/get/${pkgver}.tar.gz
+ fix-new-radare.patch)
+sha512sums=('1bec1c908bbfc5bf3dad121d98fc135a2b0ab9753077df113c7a5ca4059d3c7b86715ba2bd017fd1fa55e504e41eee4f22f76d551be4852371975ae45d3141f2'
+ '478de59f170cf5d28ab0dbe16cf9cb1d472d40de3abbe049d9577319b2123b514cd08320213a36fa2ee441add680aa56fdfc721a26ee786ed59f1d12cc1825b9')
prepare() {
- cd ${pkgname}-${pkgver}
+ cd inguma-bokken-*
+ patch -p0 < "${srcdir}/fix-new-radare.patch"
sed -e 's/env python$/env python2/g' -i ui/xdot.py lib/web/__init__.py lib/web/utils.py
sed -e 's|/usr/bin/python|/usr/bin/env python2|g' -i bokken.py
cat > bokken.sh << EOF
@@ -23,13 +27,12 @@ EOF
}
package() {
- cd ${pkgname}-${pkgver}
- install -d "${pkgdir}/usr/share/bokken"
- install -Dm 755 bokken bokken.py "${pkgdir}/usr/share/bokken"
- cp -r lib static ui "${pkgdir}/usr/share/bokken"
- install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm 644 README "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ cd inguma-bokken-*
install -Dm 755 bokken.sh "${pkgdir}/usr/bin/bokken"
+ install -Dm 755 bokken bokken.py -t "${pkgdir}/usr/share/bokken"
+ cp -r lib static ui "${pkgdir}/usr/share/bokken"
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm 644 README -t "${pkgdir}/usr/share/doc/${pkgname}"
}
# vim: ts=2 sw=2 et:
diff --git a/fix-new-radare.patch b/fix-new-radare.patch
new file mode 100644
index 000000000000..28375281bf17
--- /dev/null
+++ b/fix-new-radare.patch
@@ -0,0 +1,16 @@
+--- ui/radare_core.py
++++ ui/radare_core.py.orig
+@@ -456,8 +465,11 @@
+ if entryp:
+ self.full_fileinfo['eps'] = []
+ for line in entryp.split('\n'):
+- line = line.strip('[').strip(']')
+- self.full_fileinfo['eps'].append(['Entry0', hex(int(line))])
++ line = line.strip()
++ if line != "":
++ entries = eval(line.strip()) # fuck it, just use an eval
++ for entry in entries:
++ self.full_fileinfo['eps'].append(['Entry0', hex(entry['vaddr'])])
+ # Get symbols
+ symbols = self.send_cmd_str('is')
+ if symbols: \ No newline at end of file