summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-07-28 01:52:43 -0500
committerLuis Martinez2021-07-28 01:52:43 -0500
commite3aa54d07a282d1d33a950d3658d801c2b03d3df (patch)
tree424e27ded615293a7e891c8f18369c13f744f206
downloadaur-e3aa54d07a282d1d33a950d3658d801c2b03d3df.tar.gz
initial commit based on bombadillo-git
-rw-r--r--.SRCINFO17
-rw-r--r--001-Makefile.patch51
-rw-r--r--PKGBUILD37
3 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a209bb5c6ca0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = bombadillo
+ pkgdesc = A non-web client for the terminal, supporting Gopher, Gemini and much more.
+ pkgver = 2.3.3
+ pkgrel = 1
+ url = https://bombadillo.colorfield.space
+ arch = x86_64
+ arch = i686
+ arch = arm
+ license = GPL3
+ makedepends = go
+ depends = glibc
+ source = bombadillo-2.3.3.tar.gz::https://tildegit.org/sloum/bombadillo/archive/2.3.3.tar.gz
+ source = 001-Makefile.patch
+ sha256sums = 2d4ec15cac6d3324f13a4039cca86fecf3141503f556a6fa48bdbafb86325f1c
+ sha256sums = a379b36f6ba85a689942f90f9f4f4d416678f34c1e99bdbb8eaeadaaf6f0b788
+
+pkgname = bombadillo
diff --git a/001-Makefile.patch b/001-Makefile.patch
new file mode 100644
index 000000000000..0c8dc65f6d6e
--- /dev/null
+++ b/001-Makefile.patch
@@ -0,0 +1,51 @@
+diff --git a/Makefile b/Makefile
+index cca7657..b3296c4 100644
+--- a/Makefile
++++ b/Makefile
+@@ -22,42 +22,33 @@ install: install-bin install-man install-desktop clean
+
+ .PHONY: install-man
+ install-man: bombadillo.1
+- gzip -k ./bombadillo.1
+- install -d ${DESTDIR}${MAN1DIR}
+- install -m 0644 ./bombadillo.1.gz ${DESTDIR}${MAN1DIR}
++ install -Dm 0644 ./bombadillo.1 -t ${DESTDIR}${MAN1DIR}
+
+ .PHONY: install-desktop
+ install-desktop:
+ ifeq ($(shell uname), Linux)
+ # These steps will not work on Darwin, Plan9, or Windows
+ # They would likely work on BSD systems
+- install -d ${DESTDIR}${DATAROOTDIR}/applications
+- install -m 0644 ./bombadillo.desktop ${DESTDIR}${DATAROOTDIR}/applications
+- install -d ${DESTDIR}${DATAROOTDIR}/pixmaps
+- install -m 0644 ./bombadillo-icon.png ${DESTDIR}${DATAROOTDIR}/pixmaps
+- -update-desktop-database 2> /dev/null
++ install -Dm 0644 ./bombadillo.desktop -t ${DESTDIR}${DATAROOTDIR}/applications
++ install -Dm 0644 ./bombadillo-icon.png -t ${DESTDIR}${DATAROOTDIR}/pixmaps
+ else
+ @echo "* Skipping protocol handler associations and desktop file creation for non-linux system *"
+ endif
+
+ .PHONY: install-bin
+ install-bin: build
+- install -d ${DESTDIR}${BINDIR}
+- install -m 0755 ./${BINARY} ${DESTDIR}${BINDIR}
++ install -Dm 0755 ./${BINARY} -t ${DESTDIR}${BINDIR}
+
+ .PHONY: clean
+ clean:
+ ${GOCMD} clean
+- rm -f ./bombadillo.1.gz 2> /dev/null
+ rm -f ./${BINARY}_* 2> /dev/null
+
+ .PHONY: uninstall
+ uninstall: clean
+- rm -f ${DESTDIR}${MAN1DIR}/bombadillo.1.gz
+ rm -f ${DESTDIR}${BINDIR}/${BINARY}
+ rm -f ${DESTDIR}${DATAROOTDIR}/applications/bombadillo.desktop
+ rm -f ${DESTDIR}${DATAROOTDIR}/pixmaps/bombadillo-icon.png
+- -update-desktop-database 2> /dev/null
+
+ .PHONY: release
+ release:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a8060afc4d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Emilio Reggi <nag@mailbox.org>
+
+pkgname=bombadillo
+pkgver=2.3.3
+pkgrel=1
+pkgdesc="A non-web client for the terminal, supporting Gopher, Gemini and much more."
+arch=('x86_64' 'i686' 'arm')
+url="https://bombadillo.colorfield.space"
+license=('GPL3')
+depends=('glibc')
+makedepends=('go')
+source=("$pkgname-$pkgver.tar.gz::https://tildegit.org/sloum/bombadillo/archive/$pkgver.tar.gz"
+ 001-Makefile.patch)
+sha256sums=('2d4ec15cac6d3324f13a4039cca86fecf3141503f556a6fa48bdbafb86325f1c'
+ 'a379b36f6ba85a689942f90f9f4f4d416678f34c1e99bdbb8eaeadaaf6f0b788')
+
+prepare() {
+ cd "$pkgname"
+ patch --forward --strip=1 --input="${srcdir}/001-Makefile.patch"
+}
+
+build() {
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+
+ cd "$pkgname"
+ make PREFIX=/usr
+}
+
+package() {
+ cd "$pkgname"
+ make VERSION="$pkgver" DESTDIR="$pkgdir/" PREFIX=/usr install
+}