summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmilio Reggi2021-03-10 22:57:02 +0100
committerEmilio Reggi2021-03-10 22:57:02 +0100
commita13a0f5cc37604c03ddce99f5ae1cc0d50d796bb (patch)
tree05737b1d93f31365368489ca4021b0722c7bfd95
parente9e0fb425dd3e506cabed8d05937c91a2457f561 (diff)
downloadaur-a13a0f5cc37604c03ddce99f5ae1cc0d50d796bb.tar.gz
Patched Makefile to remove buggy update-desktop-database call
-rw-r--r--PKGBUILD14
-rw-r--r--remove-update-desktop-database.patch11
2 files changed, 21 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 64e769eacd00..9ec5b06aff40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,23 @@ pkgname=bombadillo-git
_pkgname=bombadillo
_source=https://tildegit.org/sloum/bombadillo.git
pkgver=r462.757305d
-pkgrel=3
+pkgrel=4
pkgdesc="A non-web client for the terminal, supporting Gopher, Gemini and much more."
arch=('x86_64')
url="https://tildegit.org/sloum/bombadillo.git"
license=('GPL')
-makedepends=('go' 'git' 'desktop-file-utils')
+makedepends=('go' 'git')
depends=('glibc')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-source=("${_pkgname}"::"git+${_source}")
-md5sums=('SKIP')
+source=("${_pkgname}"::"git+${_source}" "remove-update-desktop-database.patch")
+md5sums=('SKIP'
+ '181db34d11c1986d541ed8a134402f5a')
+
+prepare() {
+ cd "$_pkgname"
+ patch --forward --strip=1 --input="${srcdir}/remove-update-desktop-database.patch"
+}
pkgver() {
cd "$_pkgname"
diff --git a/remove-update-desktop-database.patch b/remove-update-desktop-database.patch
new file mode 100644
index 000000000000..6f9cd898588e
--- /dev/null
+++ b/remove-update-desktop-database.patch
@@ -0,0 +1,11 @@
+diff --unified --recursive --text bombadillo/Makefile bombadillo-patched/Makefile
+--- bombadillo/Makefile 2021-03-10 22:29:17.908090997 +0100
++++ bombadillo-patched/Makefile 2021-03-10 22:33:40.791403403 +0100
+@@ -35,7 +35,6 @@
+ install -m 0644 ./bombadillo.desktop ${DESTDIR}${DATAROOTDIR}/applications
+ install -d ${DESTDIR}${DATAROOTDIR}/pixmaps
+ install -m 0644 ./bombadillo-icon.png ${DESTDIR}${DATAROOTDIR}/pixmaps
+- -update-desktop-database 2> /dev/null
+ else
+ @echo "* Skipping protocol handler associations and desktop file creation for non-linux system *"
+ endif