summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackalope2022-03-21 10:58:38 -0500
committerJackalope2022-03-21 10:58:38 -0500
commit9c9e032351ccc7dbb19c80f6d38f36f306f8840e (patch)
tree714e4b46c28dc4bf6c6e1d46dd5ff2520cb4aab5
parentaf9b444968c53b444f50d7c862ad9a08afda7530 (diff)
downloadaur-9c9e032351ccc7dbb19c80f6d38f36f306f8840e.tar.gz
Build from source
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61346a90cdb0..b78bd59b5cc2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,7 +8,7 @@ pkgbase = bombardier
makedepends = go
options = !strip
options = !emptydirs
- source = https://github.com/codesenberg/bombardier/releases/download/v1.2.5/bombardier-linux-amd64
- b2sums = c517eada24bff73dd2b013734a2cd52e06980d9696c21834f4bd6524540061ee924aa27493c67fe30ed689bd7d731cc02034b98a5466307c92ad6f66a58589e8
+ source = bombardier::git+https://github.com/codesenberg/bombardier
+ b2sums = SKIP
pkgname = bombardier
diff --git a/PKGBUILD b/PKGBUILD
index 305eb89f578f..20173a0b84cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Olivier Biesmans <o.archlinux@biesmans.fr>
+# Maintainer: Jack Roehr <jack@seatgull.com>
pkgname=bombardier
pkgver=1.2.5
@@ -9,9 +9,14 @@ url="https://github.com/codesenberg/bombardier"
license=('MIT')
makedepends=('go')
options=('!strip' '!emptydirs')
-source=("https://github.com/codesenberg/$pkgname/releases/download/v$pkgver/bombardier-linux-amd64")
-b2sums=('c517eada24bff73dd2b013734a2cd52e06980d9696c21834f4bd6524540061ee924aa27493c67fe30ed689bd7d731cc02034b98a5466307c92ad6f66a58589e8')
+source=("bombardier::git+https://github.com/codesenberg/bombardier")
+b2sums=('SKIP')
+
+build() {
+ cd "$pkgname"
+ go build
+}
package() {
- install -Dm755 "$pkgname-linux-amd64" "$pkgdir/usr/bin/$pkgname"
+ install -Dm755 "$pkgname"/"$pkgname" "$pkgdir/usr/bin/$pkgname"
}