summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoritsme2018-08-29 02:36:49 +0800
committeritsme2018-08-29 02:36:49 +0800
commit8a6c323365206965871a8fc02cee45d4edb6c5f4 (patch)
treed01683281c0f885883fb47c909b84ef707fbc55a
parent870f4469cc1f0e57612177ba3b1166da666aa9e3 (diff)
downloadaur-bomi.tar.gz
upgrade_waf.patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD35
-rw-r--r--upgrade_waf.patch74
3 files changed, 101 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 99904452618b..c52de1f6b702 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bomi
pkgdesc = Powerful and easy-to-use GUI multimedia player based on mpv
pkgver = 0.9.11
- pkgrel = 6
+ pkgrel = 7
url = http://bomi-player.github.io
install = bomi.install
arch = i686
@@ -45,9 +45,11 @@ pkgbase = bomi
source = bomi-0.9.11.tar.gz::https://github.com/xylosper/bomi/archive/v0.9.11.tar.gz
source = ffmpeg2.8.patch
source = qml_internal_types.patch
+ source = upgrade_waf.patch
md5sums = 543c592f588c68d6f0c3cf254c288f58
md5sums = cf0ea80c4a355f935199968cb59df408
md5sums = 965ead6202472215d8cb2d875584dfb7
+ md5sums = 6bbade797cd850a576794fbf8aef0247
pkgname = bomi
diff --git a/PKGBUILD b/PKGBUILD
index 9de7237e79a5..fb13396cd810 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,14 +6,14 @@
pkgname=bomi
pkgver=0.9.11
-pkgrel=6
+pkgrel=7
pkgdesc="Powerful and easy-to-use GUI multimedia player based on mpv"
arch=('i686' 'x86_64')
-url="http://$pkgname-player.github.io"
+url="http://${pkgname}-player.github.io"
license=('GPL2')
provides=('cmplayer')
conflicts=('bomi-fresh' 'bomi-git')
-install=$pkgname.install
+install=${pkgname}.install
depends=('qt5-base' 'qt5-declarative' 'qt5-x11extras' 'qt5-quickcontrols' 'qt5-svg'
'libdvdread' 'libdvdnav' 'libcdio-paranoia' 'libcdio' 'smbclient'
'alsa-lib' 'libpulse' 'jack' 'libchardet' 'libbluray' 'hicolor-icon-theme'
@@ -24,26 +24,39 @@ optdepends=('libva-intel-driver: hardware acceleration support for Intel GPU'
'youtube-dl: streaming website support including YouTube'
'libaacs: AACS decryption for Blu-ray support'
'libbdplus: BD+ decryption for Blu-ray support')
-source=($pkgname-$pkgver.tar.gz::https://github.com/xylosper/bomi/archive/v$pkgver.tar.gz ffmpeg2.8.patch qml_internal_types.patch)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/xylosper/${pkgname}/archive/v${pkgver}.tar.gz"
+ "ffmpeg2.8.patch"
+ "qml_internal_types.patch"
+ "upgrade_waf.patch")
md5sums=('543c592f588c68d6f0c3cf254c288f58'
'cf0ea80c4a355f935199968cb59df408'
- '965ead6202472215d8cb2d875584dfb7')
+ '965ead6202472215d8cb2d875584dfb7'
+ '6bbade797cd850a576794fbf8aef0247')
#options=(debug !strip)
prepare() {
- cd "$srcdir/$pkgname-$pkgver"
- patch -p0 < "$srcdir/ffmpeg2.8.patch"
- patch -p1 < "$srcdir/qml_internal_types.patch"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p0 < "${srcdir}/ffmpeg2.8.patch"
+ patch -p1 < "${srcdir}/qml_internal_types.patch"
+
+ # While compiling mpv, an error occurs in waf python code.
+ # Upgrading waf version fixes it.
+ patch -Np1 -i $srcdir/upgrade_waf.patch
+ pushd src/mpv
+ rm waf
+ ./bootstrap.py
+ popd
}
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "${srcdir}/${pkgname}-${pkgver}"
./configure --prefix=/usr
make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- make DEST_DIR="$pkgdir/" install
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DEST_DIR="${pkgdir}/" install
}
+
diff --git a/upgrade_waf.patch b/upgrade_waf.patch
new file mode 100644
index 000000000000..c39269ceffb9
--- /dev/null
+++ b/upgrade_waf.patch
@@ -0,0 +1,74 @@
+diff --git a/src/mpv/bootstrap.py b/src/mpv/bootstrap.py
+index c62914cb..b9b6e9b6 100755
+--- a/src/mpv/bootstrap.py
++++ b/src/mpv/bootstrap.py
+@@ -5,10 +5,10 @@
+ from __future__ import print_function
+ import os, sys, stat, hashlib, subprocess
+
+-WAFRELEASE = "waf-1.8.4"
++WAFRELEASE = "waf-2.0.9"
+ WAFURLS = ["http://ftp.waf.io/pub/release/" + WAFRELEASE,
+ "http://www.freehackers.org/~tnagy/release/" + WAFRELEASE]
+-SHA256HASH = "f02035fa5d8814f33f19b2b20d43822ddef6bb39b955ca196c2a247a1f9ffaa8"
++SHA256HASH = "2a8e0816f023995e557f79ea8940d322bec18f286917c8f9a6fa2dc3875dfa48"
+
+ if os.path.exists("waf"):
+ wafver = subprocess.check_output([sys.executable, './waf', '--version']).decode()
+diff --git a/src/mpv/wscript b/src/mpv/wscript
+index d28d18fb..e659b43f 100644
+--- a/src/mpv/wscript
++++ b/src/mpv/wscript
+@@ -811,15 +811,6 @@ standalone_features = [
+ ]
+
+ _INSTALL_DIRS_LIST = [
+- ('bindir', '${PREFIX}/bin', 'binary files'),
+- ('libdir', '${PREFIX}/lib', 'library files'),
+- ('confdir', '${PREFIX}/etc/mpv', 'configuration files'),
+-
+- ('incdir', '${PREFIX}/include', 'include files'),
+-
+- ('datadir', '${PREFIX}/share', 'data files'),
+- ('mandir', '${DATADIR}/man', 'man pages '),
+- ('docdir', '${DATADIR}/doc/mpv', 'documentation files'),
+ ('zshdir', '${DATADIR}/zsh/site-functions', 'zsh completion functions'),
+ ]
+
+@@ -827,6 +818,7 @@ def options(opt):
+ opt.load('compiler_c')
+ opt.load('waf_customizations')
+ opt.load('features')
++ opt.load('gnu_dirs')
+
+ group = opt.get_option_group("build and install options")
+ for ident, default, desc in _INSTALL_DIRS_LIST:
+@@ -897,6 +889,7 @@ def configure(ctx):
+ ctx.load('dependencies')
+ ctx.load('detections.compiler')
+ ctx.load('detections.devices')
++ ctx.load('gnu_dirs')
+
+ ctx.parse_dependencies(build_options)
+ ctx.parse_dependencies(main_dependencies)
+diff --git a/src/mpv/wscript_build.py b/src/mpv/wscript_build.py
+index 0d0685b0..04d435a5 100644
+--- a/src/mpv/wscript_build.py
++++ b/src/mpv/wscript_build.py
+@@ -510,14 +510,14 @@ def build(ctx):
+ features = 'subst',
+ PREFIX = ctx.env.PREFIX,
+ LIBDIR = ctx.env.LIBDIR,
+- INCDIR = ctx.env.INCDIR,
++ INCDIR = ctx.env.INCLUDEDIR,
+ VERSION = libversion,
+ PRIV_LIBS = get_deps(),
+ )
+
+ headers = ["client.h", "qthelper.hpp", "opengl_cb.h"]
+ for f in headers:
+- ctx.install_as(ctx.env.INCDIR + '/mpv/' + f, 'libmpv/' + f)
++ ctx.install_as(ctx.env.INCLUDEDIR + '/mpv/' + f, 'libmpv/' + f)
+
+ ctx.install_as(ctx.env.LIBDIR + '/pkgconfig/mpv.pc', 'libmpv/mpv.pc')
+