summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoritsme2017-12-15 17:49:22 +0800
committeritsme2017-12-15 17:49:22 +0800
commit041c15ba0c7fdc776b1366e5d4fb8fefdfdc9f57 (patch)
treeed7b057130f5bd182cbe7a88ce5e0ca4dd25af0b
parent90a938438cb83f8556d36c0424e3d27bcb99bc93 (diff)
downloadaur-041c15ba0c7fdc776b1366e5d4fb8fefdfdc9f57.tar.gz
qml_internal_types.patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--qml_internal_types.patch11
3 files changed, 20 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53e034737d3e..9eb43c533798 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bomi
pkgdesc = Powerful and easy-to-use GUI multimedia player based on mpv
pkgver = 0.9.11
- pkgrel = 4
+ pkgrel = 5
url = http://bomi-player.github.io
install = bomi.install
arch = i686
@@ -44,8 +44,10 @@ pkgbase = bomi
conflicts = bomi-git
source = bomi-0.9.11.tar.gz::https://github.com/xylosper/bomi/archive/v0.9.11.tar.gz
source = ffmpeg2.8.patch
+ source = qml_internal_types.patch
md5sums = 543c592f588c68d6f0c3cf254c288f58
md5sums = 7bb39aea99bb5c0f6607cda44edc11ae
+ md5sums = 965ead6202472215d8cb2d875584dfb7
pkgname = bomi
diff --git a/PKGBUILD b/PKGBUILD
index ad2e96ff24c2..cd65bc38518b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=bomi
pkgver=0.9.11
-pkgrel=4
+pkgrel=5
pkgdesc="Powerful and easy-to-use GUI multimedia player based on mpv"
arch=('i686' 'x86_64')
url="http://$pkgname-player.github.io"
@@ -24,15 +24,17 @@ optdepends=('libva-intel-driver: hardware acceleration support for Intel GPU'
'youtube-dl: streaming website support including YouTube'
'libaacs: AACS decryption for Blu-ray support'
'libbdplus: BD+ decryption for Blu-ray support')
-source=($pkgname-$pkgver.tar.gz::https://github.com/xylosper/bomi/archive/v$pkgver.tar.gz ffmpeg2.8.patch)
+source=($pkgname-$pkgver.tar.gz::https://github.com/xylosper/bomi/archive/v$pkgver.tar.gz ffmpeg2.8.patch qml_internal_types.patch)
md5sums=('543c592f588c68d6f0c3cf254c288f58'
- '7bb39aea99bb5c0f6607cda44edc11ae')
+ '7bb39aea99bb5c0f6607cda44edc11ae'
+ '965ead6202472215d8cb2d875584dfb7')
#options=(debug !strip)
prepare() {
cd "$srcdir/$pkgname-$pkgver"
- patch -p0 < "../ffmpeg2.8.patch"
+ patch -p0 < "$srcdir/ffmpeg2.8.patch"
+ patch -p1 < "$srcdir/qml_internal_types.patch"
}
build() {
diff --git a/qml_internal_types.patch b/qml_internal_types.patch
new file mode 100644
index 000000000000..ab1d55c69efa
--- /dev/null
+++ b/qml_internal_types.patch
@@ -0,0 +1,11 @@
+diff --git a/src/bomi/imports/bomi/qmldir b/src/bomi/imports/bomi/qmldir
+index 307cc33c..79d3e8b5 100644
+--- a/src/bomi/imports/bomi/qmldir
++++ b/src/bomi/imports/bomi/qmldir
+@@ -35,3 +35,6 @@ SimpleBlur 1.0 SimpleBlur.qml
+ ToolPlaneStyle 1.0 ToolPlaneStyle.qml
+ BarVisualizer 1.0 BarVisualizer.qml
+ StateButton 1.0 StateButton.qml
++internal Osd Osd.qml
++internal PlayInfoText PlayInfoText.qml
++internal PlayInfoTrack PlayInfoTrack.qml