summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro Gabriel Drumond Pereira2015-08-04 23:02:25 -0300
committerPedro Gabriel Drumond Pereira2015-08-04 23:02:25 -0300
commit340331a9d11b71390dce311b62d573c5316c6b1e (patch)
treec70de472b6fbf59841733a37c84d4a94d5bb3f1a
downloadaur-340331a9d11b71390dce311b62d573c5316c6b1e.tar.gz
Initial import
-rw-r--r--.SRCINFO46
-rw-r--r--PKGBUILD36
-rw-r--r--bomi.install12
3 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ebb67bd73078
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,46 @@
+pkgbase = bomi
+ pkgdesc = Powerful and easy-to-use GUI multimedia player based on mpv
+ pkgver = 0.9.11
+ pkgrel = 1
+ url = http://bomi-player.github.io
+ install = bomi.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = mesa
+ makedepends = gcc
+ makedepends = pkg-config
+ makedepends = python
+ makedepends = qt5-tools
+ depends = qt5-base
+ depends = qt5-declarative
+ depends = qt5-x11extras
+ depends = qt5-quickcontrols
+ depends = qt5-svg
+ depends = libdvdread
+ depends = libdvdnav
+ depends = libcdio-paranoia
+ depends = libcdio
+ depends = smbclient
+ depends = alsa-lib
+ depends = libpulse
+ depends = jack
+ depends = libchardet
+ depends = libbluray
+ depends = libva
+ depends = libvdpau
+ depends = libgl
+ depends = fribidi
+ depends = libass
+ depends = ffmpeg
+ optdepends = libva-intel-driver: hardware acceleration support for Intel GPU
+ optdepends = mesa-vdpau: hardware acceleration support for AMD/NVIDIA opensource driver
+ optdepends = youtube-dl: streaming website support including YouTube
+ optdepends = libaacs: AACS decryption for Blu-ray support
+ optdepends = libbdplus: BD+ decryption for Blu-ray support
+ provides = cmplayer
+ source = bomi-0.9.11.tar.gz::https://github.com/xylosper/bomi/archive/v0.9.11.tar.gz
+ md5sums = 543c592f588c68d6f0c3cf254c288f58
+
+pkgname = bomi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea76dfa5949d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: xylosper <darklin20@gmail.com>
+# Contributor: willemw <willemw12@gmail.com>
+
+pkgname=bomi
+pkgver=0.9.11
+pkgrel=1
+pkgdesc="Powerful and easy-to-use GUI multimedia player based on mpv"
+arch=('i686' 'x86_64')
+url="http://$pkgname-player.github.io"
+license=('GPL')
+provides=('cmplayer')
+install=$pkgname.install
+depends=('qt5-base' 'qt5-declarative' 'qt5-x11extras' 'qt5-quickcontrols' 'qt5-svg'
+ 'libdvdread' 'libdvdnav' 'libcdio-paranoia' 'libcdio' 'smbclient'
+ 'alsa-lib' 'libpulse' 'jack' 'libchardet' 'libbluray'
+ 'libva' 'libvdpau' 'libgl' 'fribidi' 'libass' 'ffmpeg')
+makedepends=('mesa' 'gcc' 'pkg-config' 'python' 'qt5-tools')
+optdepends=('libva-intel-driver: hardware acceleration support for Intel GPU'
+ 'mesa-vdpau: hardware acceleration support for AMD/NVIDIA opensource driver'
+ 'youtube-dl: streaming website support including YouTube'
+ 'libaacs: AACS decryption for Blu-ray support'
+ 'libbdplus: BD+ decryption for Blu-ray support')
+source=($pkgname-$pkgver.tar.gz::https://github.com/xylosper/bomi/archive/v$pkgver.tar.gz)
+md5sums=('543c592f588c68d6f0c3cf254c288f58')
+#options=(debug !strip)
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DEST_DIR=$pkgdir install
+}
diff --git a/bomi.install b/bomi.install
new file mode 100644
index 000000000000..6481cee07145
--- /dev/null
+++ b/bomi.install
@@ -0,0 +1,12 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}