summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobin Broda2018-02-19 22:22:42 +0100
committerRobin Broda2018-02-19 22:22:42 +0100
commit36a658afe14bd93cd372088151d30f8af1f1d24d (patch)
tree60f8e201d44dd82179bdde2788684103eff3d059
downloadaur-36a658afe14bd93cd372088151d30f8af1f1d24d.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD40
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..551f092d8975
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = bonzomatic-git
+ pkgdesc = a live-coding tool where you can write a 2D fragment/pixel shader while it is running in the background
+ pkgver = r284.362c1de
+ pkgrel = 1
+ url = https://github.com/Gargaj/bonzomatic
+ arch = x86_64
+ license = custom:Unlicense
+ makedepends = git
+ makedepends = cmake
+ makedepends = glu
+ depends = xorg-server
+ depends = libxrandr
+ depends = libxinerama
+ depends = libxcursor
+ depends = libbass
+ provides = bonzomatic
+ conflicts = bonzomatic
+ source = git+https://github.com/Gargaj/bonzomatic.git
+ md5sums = SKIP
+
+pkgname = bonzomatic-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f4c8587ff57
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Robin Broda <robin at broda dot me>
+
+_pkgname="bonzomatic"
+pkgname=("${_pkgname}-git")
+pkgver=r284.362c1de
+pkgrel=1
+pkgdesc='a live-coding tool where you can write a 2D fragment/pixel shader while it is running in the background'
+arch=('x86_64')
+url='https://github.com/Gargaj/bonzomatic'
+license=('custom:Unlicense')
+provides=('bonzomatic')
+conflicts=('bonzomatic')
+depends=('xorg-server' 'libxrandr' 'libxinerama' 'libxcursor' 'libbass')
+makedepends=('git' 'cmake' 'glu')
+source=('git+https://github.com/Gargaj/bonzomatic.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${_pkgname}"
+
+ mkdir build && cd build && cmake ..
+}
+
+build() {
+ cd "${_pkgname}/build"
+
+ make
+}
+
+package() {
+ cd "${_pkgname}/build"
+
+ install -Dm755 Bonzomatic "${pkgdir}/usr/bin/Bonzomatic"
+ install -Dm644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}