summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobin Broda2018-02-20 03:46:34 +0100
committerRobin Broda2018-02-20 03:47:05 +0100
commitbfc376c28a104526a659328866e5aa89b75f9366 (patch)
tree5fec56988eac85fe1d8496e60accae1c2d5b8e72
parentb8d4411b0a96fecae05bdaff89c0e2259f43c5b1 (diff)
downloadaur-bfc376c28a104526a659328866e5aa89b75f9366.tar.gz
Remove insecure rpath from binary
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 551f092d8975..b14e81dfb3b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = bonzomatic-git
pkgdesc = a live-coding tool where you can write a 2D fragment/pixel shader while it is running in the background
pkgver = r284.362c1de
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Gargaj/bonzomatic
arch = x86_64
license = custom:Unlicense
makedepends = git
makedepends = cmake
makedepends = glu
+ makedepends = chrpath
depends = xorg-server
depends = libxrandr
depends = libxinerama
diff --git a/PKGBUILD b/PKGBUILD
index f3127f60ee57..5daca43a60b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname="bonzomatic"
pkgname=("${_pkgname}-git")
pkgver=r284.362c1de
-pkgrel=1
+pkgrel=2
pkgdesc='a live-coding tool where you can write a 2D fragment/pixel shader while it is running in the background'
arch=('x86_64')
url='https://github.com/Gargaj/bonzomatic'
@@ -11,7 +11,7 @@ license=('custom:Unlicense')
provides=('bonzomatic')
conflicts=('bonzomatic')
depends=('xorg-server' 'libxrandr' 'libxinerama' 'libxcursor' 'libbass')
-makedepends=('git' 'cmake' 'glu')
+makedepends=('git' 'cmake' 'glu' 'chrpath')
source=('git+https://github.com/Gargaj/bonzomatic.git')
md5sums=('SKIP')
@@ -36,6 +36,9 @@ build() {
package() {
cd "${_pkgname}/build"
+ # Fix insecure rpath
+ chrpath -d Bonzomatic
+
install -Dm755 Bonzomatic "${pkgdir}/usr/bin/Bonzomatic"
install -Dm644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}