summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2017-10-24 07:21:06 +0000
committerAntonio Rojas2017-10-24 07:21:06 +0000
commit62a7ae4b431cb6e626b1da8a3dbfe381e3ead2f6 (patch)
tree54d054674737567ac6903c2afa3772aa6153c561
downloadaur-62a7ae4b431cb6e626b1da8a3dbfe381e3ead2f6.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
-rw-r--r--PKGBUILD-namcap.log0
-rw-r--r--boo-0.9.4.9-4-i686-build.log38
-rw-r--r--boo-0.9.4.9-4-i686-package.log58
-rw-r--r--boo-0.9.4.9-4-i686.pkg.tar.xz-namcap.log3
-rw-r--r--boo-0.9.4.9-4-x86_64-build.log38
-rw-r--r--boo-0.9.4.9-4-x86_64-package.log58
-rw-r--r--boo-0.9.4.9-4-x86_64.pkg.tar.xz-namcap.log3
9 files changed, 249 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a49820ac29c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = boo
+ pkgdesc = A wrist friendly language for the CLI
+ pkgver = 0.9.4.9
+ pkgrel = 4
+ url = http://boo.codehaus.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = sh
+ depends = mono
+ depends = shared-mime-info
+ options = !makeflags
+ source = https://sources.archlinux.org/other/packages/boo/boo-0.9.4.9.tar.gz
+ md5sums = e8b04c63d4c983f82e8a2b2d49115c80
+ sha1sums = fdd0f91ae1b2917d83fc8fa7f4610e3c22c06bf9
+
+pkgname = boo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67bbfc8081c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 273486 2016-08-07 22:55:07Z arojas $
+# Maintainer: Hugo Doria <hugo@archlinux.org>
+# Contributor: tardo <tardo@nagi-fanboi.net>
+# Contributor: Brice Carpentier <brice@dlfp.org>
+
+pkgname=boo
+pkgver=0.9.4.9
+pkgrel=4
+pkgdesc="A wrist friendly language for the CLI"
+arch=('i686' 'x86_64')
+url="http://boo.codehaus.org/"
+license=('GPL')
+depends=('sh' 'mono' 'shared-mime-info')
+options=('!makeflags')
+source=(https://sources.archlinux.org/other/packages/boo/boo-$pkgver.tar.gz)
+md5sums=('e8b04c63d4c983f82e8a2b2d49115c80')
+sha1sums=('fdd0f91ae1b2917d83fc8fa7f4610e3c22c06bf9')
+
+build() {
+ export MONO_SHARED_DIR="${srcdir}/.wabi"
+ mkdir -p $MONO_SHARED_DIR
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ sed -i -e 's|/lib|/lib/mono|' extras/boo.pc.in
+ ./configure --prefix=/usr --libdir=/usr/lib
+ make VERBOSE=1
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}/share/"
+ rm -rf "${pkgdir}/usr/share/gtksourceview-1.0/language-specs/boo.lang"
+}
diff --git a/PKGBUILD-namcap.log b/PKGBUILD-namcap.log
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/PKGBUILD-namcap.log
diff --git a/boo-0.9.4.9-4-i686-build.log b/boo-0.9.4.9-4-i686-build.log
new file mode 100644
index 000000000000..07cbe3f698f2
--- /dev/null
+++ b/boo-0.9.4.9-4-i686-build.log
@@ -0,0 +1,38 @@
+checking for a BSD-compatible install... /usr/bin/install -c
+checking whether build environment is sane... yes
+checking for a thread-safe mkdir -p... /usr/bin/mkdir -p
+checking for gawk... gawk
+checking whether make sets $(MAKE)... yes
+checking for pkg-config... /usr/bin/pkg-config
+Package gtksourceview-1.0 was not found in the pkg-config search path.
+Perhaps you should add the directory containing `gtksourceview-1.0.pc'
+to the PKG_CONFIG_PATH environment variable
+No package 'gtksourceview-1.0' found
+checking for mono... /usr/bin/mono
+checking for gacutil... /usr/bin/gacutil
+configure: creating ./config.status
+config.status: creating Makefile
+config.status: creating bin/Makefile
+config.status: creating extras/Makefile
+config.status: creating extras/booc
+config.status: creating extras/booi
+config.status: creating extras/booish
+config.status: creating extras/boo.pc
+
+ Summary:
+
+ shared-mime-info prefix: /usr
+ gtksourceview-1.0 prefix:
+ boo prefix: /usr
+
+Making all in bin
+make[1]: Entering directory '/build/boo/src/boo-0.9.4.9/bin'
+make[1]: Nothing to be done for 'all'.
+make[1]: Leaving directory '/build/boo/src/boo-0.9.4.9/bin'
+Making all in extras
+make[1]: Entering directory '/build/boo/src/boo-0.9.4.9/extras'
+make[1]: Nothing to be done for 'all'.
+make[1]: Leaving directory '/build/boo/src/boo-0.9.4.9/extras'
+make[1]: Entering directory '/build/boo/src/boo-0.9.4.9'
+make[1]: Nothing to be done for 'all-am'.
+make[1]: Leaving directory '/build/boo/src/boo-0.9.4.9'
diff --git a/boo-0.9.4.9-4-i686-package.log b/boo-0.9.4.9-4-i686-package.log
new file mode 100644
index 000000000000..cacfe5b32502
--- /dev/null
+++ b/boo-0.9.4.9-4-i686-package.log
@@ -0,0 +1,58 @@
+Making install in bin
+make[1]: Entering directory '/build/boo/src/boo-0.9.4.9/bin'
+make[2]: Entering directory '/build/boo/src/boo-0.9.4.9/bin'
+make[2]: Nothing to be done for 'install-exec-am'.
+test -z "/usr/lib/boo" || /usr/bin/mkdir -p "/build/boo/pkg/boo/usr/lib/boo"
+ /usr/bin/install -c -m 644 booc.exe booi.exe booish.exe booc.rsp booc.exe.config booi.exe.config booish.exe.config Boo.NAnt.Tasks.dll '/build/boo/pkg/boo/usr/lib/boo'
+make install-data-hook
+make[3]: Entering directory '/build/boo/src/boo-0.9.4.9/bin'
+for lib in Boo.Lang.dll Boo.Lang.Useful.dll Boo.Lang.Extensions.dll Boo.Lang.Compiler.dll Boo.Lang.Parser.dll Boo.Lang.Interpreter.dll Boo.Lang.PatternMatching.dll Boo.Lang.CodeDom.dll; do \
+ echo "/usr/bin/gacutil /i ${lib} /package boo /gacdir /build/boo/pkg/boo//usr/lib" ; \
+ /usr/bin/gacutil /i ${lib} /package boo /gacdir /build/boo/pkg/boo//usr/lib || exit 1 ; \
+done
+/usr/bin/gacutil /i Boo.Lang.dll /package boo /gacdir /build/boo/pkg/boo//usr/lib
+Package exported to: /build/boo/pkg/boo//usr/lib/mono/boo/Boo.Lang.dll -> ../gac/Boo.Lang/2.0.9.4__32c39770e9a21a67/Boo.Lang.dll
+Installed Boo.Lang.dll into the gac (/build/boo/pkg/boo//usr/lib/mono/gac)
+/usr/bin/gacutil /i Boo.Lang.Useful.dll /package boo /gacdir /build/boo/pkg/boo//usr/lib
+Package exported to: /build/boo/pkg/boo//usr/lib/mono/boo/Boo.Lang.Useful.dll -> ../gac/Boo.Lang.Useful/2.0.9.4__32c39770e9a21a67/Boo.Lang.Useful.dll
+Installed Boo.Lang.Useful.dll into the gac (/build/boo/pkg/boo//usr/lib/mono/gac)
+/usr/bin/gacutil /i Boo.Lang.Extensions.dll /package boo /gacdir /build/boo/pkg/boo//usr/lib
+Package exported to: /build/boo/pkg/boo//usr/lib/mono/boo/Boo.Lang.Extensions.dll -> ../gac/Boo.Lang.Extensions/2.0.9.4__32c39770e9a21a67/Boo.Lang.Extensions.dll
+Installed Boo.Lang.Extensions.dll into the gac (/build/boo/pkg/boo//usr/lib/mono/gac)
+/usr/bin/gacutil /i Boo.Lang.Compiler.dll /package boo /gacdir /build/boo/pkg/boo//usr/lib
+Package exported to: /build/boo/pkg/boo//usr/lib/mono/boo/Boo.Lang.Compiler.dll -> ../gac/Boo.Lang.Compiler/2.0.9.4__32c39770e9a21a67/Boo.Lang.Compiler.dll
+Installed Boo.Lang.Compiler.dll into the gac (/build/boo/pkg/boo//usr/lib/mono/gac)
+/usr/bin/gacutil /i Boo.Lang.Parser.dll /package boo /gacdir /build/boo/pkg/boo//usr/lib
+Package exported to: /build/boo/pkg/boo//usr/lib/mono/boo/Boo.Lang.Parser.dll -> ../gac/Boo.Lang.Parser/2.0.9.4__32c39770e9a21a67/Boo.Lang.Parser.dll
+Installed Boo.Lang.Parser.dll into the gac (/build/boo/pkg/boo//usr/lib/mono/gac)
+/usr/bin/gacutil /i Boo.Lang.Interpreter.dll /package boo /gacdir /build/boo/pkg/boo//usr/lib
+Package exported to: /build/boo/pkg/boo//usr/lib/mono/boo/Boo.Lang.Interpreter.dll -> ../gac/Boo.Lang.Interpreter/2.0.9.4__32c39770e9a21a67/Boo.Lang.Interpreter.dll
+Installed Boo.Lang.Interpreter.dll into the gac (/build/boo/pkg/boo//usr/lib/mono/gac)
+/usr/bin/gacutil /i Boo.Lang.PatternMatching.dll /package boo /gacdir /build/boo/pkg/boo//usr/lib
+Package exported to: /build/boo/pkg/boo//usr/lib/mono/boo/Boo.Lang.PatternMatching.dll -> ../gac/Boo.Lang.PatternMatching/2.0.9.4__32c39770e9a21a67/Boo.Lang.PatternMatching.dll
+Installed Boo.Lang.PatternMatching.dll into the gac (/build/boo/pkg/boo//usr/lib/mono/gac)
+/usr/bin/gacutil /i Boo.Lang.CodeDom.dll /package boo /gacdir /build/boo/pkg/boo//usr/lib
+Package exported to: /build/boo/pkg/boo//usr/lib/mono/boo/Boo.Lang.CodeDom.dll -> ../gac/Boo.Lang.CodeDom/2.0.9.4__32c39770e9a21a67/Boo.Lang.CodeDom.dll
+Installed Boo.Lang.CodeDom.dll into the gac (/build/boo/pkg/boo//usr/lib/mono/gac)
+make[3]: Leaving directory '/build/boo/src/boo-0.9.4.9/bin'
+make[2]: Leaving directory '/build/boo/src/boo-0.9.4.9/bin'
+make[1]: Leaving directory '/build/boo/src/boo-0.9.4.9/bin'
+Making install in extras
+make[1]: Entering directory '/build/boo/src/boo-0.9.4.9/extras'
+make[2]: Entering directory '/build/boo/src/boo-0.9.4.9/extras'
+test -z "/usr/bin" || /usr/bin/mkdir -p "/build/boo/pkg/boo/usr/bin"
+ /usr/bin/install -c booc booi booish '/build/boo/pkg/boo/usr/bin'
+test -z "/share/gtksourceview-1.0/language-specs/" || /usr/bin/mkdir -p "/build/boo/pkg/boo/share/gtksourceview-1.0/language-specs/"
+ /usr/bin/install -c -m 644 boo.lang '/build/boo/pkg/boo/share/gtksourceview-1.0/language-specs/'
+test -z "/usr/share/mime/packages/" || /usr/bin/mkdir -p "/build/boo/pkg/boo/usr/share/mime/packages/"
+ /usr/bin/install -c -m 644 boo-mime-info.xml '/build/boo/pkg/boo/usr/share/mime/packages/'
+test -z "/usr/lib/pkgconfig" || /usr/bin/mkdir -p "/build/boo/pkg/boo/usr/lib/pkgconfig"
+ /usr/bin/install -c -m 644 boo.pc '/build/boo/pkg/boo/usr/lib/pkgconfig'
+make[2]: Leaving directory '/build/boo/src/boo-0.9.4.9/extras'
+make[1]: Leaving directory '/build/boo/src/boo-0.9.4.9/extras'
+make[1]: Entering directory '/build/boo/src/boo-0.9.4.9'
+make[2]: Entering directory '/build/boo/src/boo-0.9.4.9'
+make[2]: Nothing to be done for 'install-exec-am'.
+make[2]: Nothing to be done for 'install-data-am'.
+make[2]: Leaving directory '/build/boo/src/boo-0.9.4.9'
+make[1]: Leaving directory '/build/boo/src/boo-0.9.4.9'
diff --git a/boo-0.9.4.9-4-i686.pkg.tar.xz-namcap.log b/boo-0.9.4.9-4-i686.pkg.tar.xz-namcap.log
new file mode 100644
index 000000000000..6523eef4dd5f
--- /dev/null
+++ b/boo-0.9.4.9-4-i686.pkg.tar.xz-namcap.log
@@ -0,0 +1,3 @@
+boo W: No ELF files and not an "any" package
+boo W: Dependency included and not needed ('mono')
+boo W: Dependency included and not needed ('shared-mime-info')
diff --git a/boo-0.9.4.9-4-x86_64-build.log b/boo-0.9.4.9-4-x86_64-build.log
new file mode 100644
index 000000000000..07cbe3f698f2
--- /dev/null
+++ b/boo-0.9.4.9-4-x86_64-build.log
@@ -0,0 +1,38 @@
+checking for a BSD-compatible install... /usr/bin/install -c
+checking whether build environment is sane... yes
+checking for a thread-safe mkdir -p... /usr/bin/mkdir -p
+checking for gawk... gawk
+checking whether make sets $(MAKE)... yes
+checking for pkg-config... /usr/bin/pkg-config
+Package gtksourceview-1.0 was not found in the pkg-config search path.
+Perhaps you should add the directory containing `gtksourceview-1.0.pc'
+to the PKG_CONFIG_PATH environment variable
+No package 'gtksourceview-1.0' found
+checking for mono... /usr/bin/mono
+checking for gacutil... /usr/bin/gacutil
+configure: creating ./config.status
+config.status: creating Makefile
+config.status: creating bin/Makefile
+config.status: creating extras/Makefile
+config.status: creating extras/booc
+config.status: creating extras/booi
+config.status: creating extras/booish
+config.status: creating extras/boo.pc
+
+ Summary:
+
+ shared-mime-info prefix: /usr
+ gtksourceview-1.0 prefix:
+ boo prefix: /usr
+
+Making all in bin
+make[1]: Entering directory '/build/boo/src/boo-0.9.4.9/bin'
+make[1]: Nothing to be done for 'all'.
+make[1]: Leaving directory '/build/boo/src/boo-0.9.4.9/bin'
+Making all in extras
+make[1]: Entering directory '/build/boo/src/boo-0.9.4.9/extras'
+make[1]: Nothing to be done for 'all'.
+make[1]: Leaving directory '/build/boo/src/boo-0.9.4.9/extras'
+make[1]: Entering directory '/build/boo/src/boo-0.9.4.9'
+make[1]: Nothing to be done for 'all-am'.
+make[1]: Leaving directory '/build/boo/src/boo-0.9.4.9'
diff --git a/boo-0.9.4.9-4-x86_64-package.log b/boo-0.9.4.9-4-x86_64-package.log
new file mode 100644
index 000000000000..cacfe5b32502
--- /dev/null
+++ b/boo-0.9.4.9-4-x86_64-package.log
@@ -0,0 +1,58 @@
+Making install in bin
+make[1]: Entering directory '/build/boo/src/boo-0.9.4.9/bin'
+make[2]: Entering directory '/build/boo/src/boo-0.9.4.9/bin'
+make[2]: Nothing to be done for 'install-exec-am'.
+test -z "/usr/lib/boo" || /usr/bin/mkdir -p "/build/boo/pkg/boo/usr/lib/boo"
+ /usr/bin/install -c -m 644 booc.exe booi.exe booish.exe booc.rsp booc.exe.config booi.exe.config booish.exe.config Boo.NAnt.Tasks.dll '/build/boo/pkg/boo/usr/lib/boo'
+make install-data-hook
+make[3]: Entering directory '/build/boo/src/boo-0.9.4.9/bin'
+for lib in Boo.Lang.dll Boo.Lang.Useful.dll Boo.Lang.Extensions.dll Boo.Lang.Compiler.dll Boo.Lang.Parser.dll Boo.Lang.Interpreter.dll Boo.Lang.PatternMatching.dll Boo.Lang.CodeDom.dll; do \
+ echo "/usr/bin/gacutil /i ${lib} /package boo /gacdir /build/boo/pkg/boo//usr/lib" ; \
+ /usr/bin/gacutil /i ${lib} /package boo /gacdir /build/boo/pkg/boo//usr/lib || exit 1 ; \
+done
+/usr/bin/gacutil /i Boo.Lang.dll /package boo /gacdir /build/boo/pkg/boo//usr/lib
+Package exported to: /build/boo/pkg/boo//usr/lib/mono/boo/Boo.Lang.dll -> ../gac/Boo.Lang/2.0.9.4__32c39770e9a21a67/Boo.Lang.dll
+Installed Boo.Lang.dll into the gac (/build/boo/pkg/boo//usr/lib/mono/gac)
+/usr/bin/gacutil /i Boo.Lang.Useful.dll /package boo /gacdir /build/boo/pkg/boo//usr/lib
+Package exported to: /build/boo/pkg/boo//usr/lib/mono/boo/Boo.Lang.Useful.dll -> ../gac/Boo.Lang.Useful/2.0.9.4__32c39770e9a21a67/Boo.Lang.Useful.dll
+Installed Boo.Lang.Useful.dll into the gac (/build/boo/pkg/boo//usr/lib/mono/gac)
+/usr/bin/gacutil /i Boo.Lang.Extensions.dll /package boo /gacdir /build/boo/pkg/boo//usr/lib
+Package exported to: /build/boo/pkg/boo//usr/lib/mono/boo/Boo.Lang.Extensions.dll -> ../gac/Boo.Lang.Extensions/2.0.9.4__32c39770e9a21a67/Boo.Lang.Extensions.dll
+Installed Boo.Lang.Extensions.dll into the gac (/build/boo/pkg/boo//usr/lib/mono/gac)
+/usr/bin/gacutil /i Boo.Lang.Compiler.dll /package boo /gacdir /build/boo/pkg/boo//usr/lib
+Package exported to: /build/boo/pkg/boo//usr/lib/mono/boo/Boo.Lang.Compiler.dll -> ../gac/Boo.Lang.Compiler/2.0.9.4__32c39770e9a21a67/Boo.Lang.Compiler.dll
+Installed Boo.Lang.Compiler.dll into the gac (/build/boo/pkg/boo//usr/lib/mono/gac)
+/usr/bin/gacutil /i Boo.Lang.Parser.dll /package boo /gacdir /build/boo/pkg/boo//usr/lib
+Package exported to: /build/boo/pkg/boo//usr/lib/mono/boo/Boo.Lang.Parser.dll -> ../gac/Boo.Lang.Parser/2.0.9.4__32c39770e9a21a67/Boo.Lang.Parser.dll
+Installed Boo.Lang.Parser.dll into the gac (/build/boo/pkg/boo//usr/lib/mono/gac)
+/usr/bin/gacutil /i Boo.Lang.Interpreter.dll /package boo /gacdir /build/boo/pkg/boo//usr/lib
+Package exported to: /build/boo/pkg/boo//usr/lib/mono/boo/Boo.Lang.Interpreter.dll -> ../gac/Boo.Lang.Interpreter/2.0.9.4__32c39770e9a21a67/Boo.Lang.Interpreter.dll
+Installed Boo.Lang.Interpreter.dll into the gac (/build/boo/pkg/boo//usr/lib/mono/gac)
+/usr/bin/gacutil /i Boo.Lang.PatternMatching.dll /package boo /gacdir /build/boo/pkg/boo//usr/lib
+Package exported to: /build/boo/pkg/boo//usr/lib/mono/boo/Boo.Lang.PatternMatching.dll -> ../gac/Boo.Lang.PatternMatching/2.0.9.4__32c39770e9a21a67/Boo.Lang.PatternMatching.dll
+Installed Boo.Lang.PatternMatching.dll into the gac (/build/boo/pkg/boo//usr/lib/mono/gac)
+/usr/bin/gacutil /i Boo.Lang.CodeDom.dll /package boo /gacdir /build/boo/pkg/boo//usr/lib
+Package exported to: /build/boo/pkg/boo//usr/lib/mono/boo/Boo.Lang.CodeDom.dll -> ../gac/Boo.Lang.CodeDom/2.0.9.4__32c39770e9a21a67/Boo.Lang.CodeDom.dll
+Installed Boo.Lang.CodeDom.dll into the gac (/build/boo/pkg/boo//usr/lib/mono/gac)
+make[3]: Leaving directory '/build/boo/src/boo-0.9.4.9/bin'
+make[2]: Leaving directory '/build/boo/src/boo-0.9.4.9/bin'
+make[1]: Leaving directory '/build/boo/src/boo-0.9.4.9/bin'
+Making install in extras
+make[1]: Entering directory '/build/boo/src/boo-0.9.4.9/extras'
+make[2]: Entering directory '/build/boo/src/boo-0.9.4.9/extras'
+test -z "/usr/bin" || /usr/bin/mkdir -p "/build/boo/pkg/boo/usr/bin"
+ /usr/bin/install -c booc booi booish '/build/boo/pkg/boo/usr/bin'
+test -z "/share/gtksourceview-1.0/language-specs/" || /usr/bin/mkdir -p "/build/boo/pkg/boo/share/gtksourceview-1.0/language-specs/"
+ /usr/bin/install -c -m 644 boo.lang '/build/boo/pkg/boo/share/gtksourceview-1.0/language-specs/'
+test -z "/usr/share/mime/packages/" || /usr/bin/mkdir -p "/build/boo/pkg/boo/usr/share/mime/packages/"
+ /usr/bin/install -c -m 644 boo-mime-info.xml '/build/boo/pkg/boo/usr/share/mime/packages/'
+test -z "/usr/lib/pkgconfig" || /usr/bin/mkdir -p "/build/boo/pkg/boo/usr/lib/pkgconfig"
+ /usr/bin/install -c -m 644 boo.pc '/build/boo/pkg/boo/usr/lib/pkgconfig'
+make[2]: Leaving directory '/build/boo/src/boo-0.9.4.9/extras'
+make[1]: Leaving directory '/build/boo/src/boo-0.9.4.9/extras'
+make[1]: Entering directory '/build/boo/src/boo-0.9.4.9'
+make[2]: Entering directory '/build/boo/src/boo-0.9.4.9'
+make[2]: Nothing to be done for 'install-exec-am'.
+make[2]: Nothing to be done for 'install-data-am'.
+make[2]: Leaving directory '/build/boo/src/boo-0.9.4.9'
+make[1]: Leaving directory '/build/boo/src/boo-0.9.4.9'
diff --git a/boo-0.9.4.9-4-x86_64.pkg.tar.xz-namcap.log b/boo-0.9.4.9-4-x86_64.pkg.tar.xz-namcap.log
new file mode 100644
index 000000000000..6523eef4dd5f
--- /dev/null
+++ b/boo-0.9.4.9-4-x86_64.pkg.tar.xz-namcap.log
@@ -0,0 +1,3 @@
+boo W: No ELF files and not an "any" package
+boo W: Dependency included and not needed ('mono')
+boo W: Dependency included and not needed ('shared-mime-info')