summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Wellhöfer2020-04-26 09:34:09 +0200
committerJohannes Wellhöfer2020-04-26 09:34:09 +0200
commit8c9a04db06c8f82109890f6f93546f4a8a6da447 (patch)
treecae3476d90f511c4960fc8258f65c2ded2718548
parentba96fc681ae2ef6de223a9c04817751c10d81398 (diff)
downloadaur-8c9a04db06c8f82109890f6f93546f4a8a6da447.tar.gz
update PKGBUILD
update maintainer use nuget from repo instead of downloaded blob update PKGBUILD url field
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2b56b08337be..6ac0ad043f26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
-# Maintainer: Florian Hahn <flo@fhahn.com>
+# Maintainer: Johannes Wellhöfer <johannes.wellhoefer+aur@gmail.com>
+# Contributor : Florian Hahn <flo@fhahn.com>
pkgname=boogie-git
pkgdesc='Boogie is an Intermediate Verification Language (IVL) for describing proof obligations to be discharged by a
reasoning engine, typically an SMT solver'
license=('custom: Ms-Pl')
-pkgver=0.r4273.bad6c01
+pkgver=0.r5030.8448ac1c
pkgrel=1
depends=('z3-git' 'mono')
-makedepends=('mercurial' 'wget')
+makedepends=('mercurial' 'wget' 'nuget>=2.12' )
conflicts=('boogie')
provides=('boogie')
arch=('any')
-url=('http://boogie.codeplex.com')
-source=("$pkgname"::'git+https://github.com/boogie-org/boogie.git'
+url='https://github.com/boogie-org/boogie'
+source=($pkgname::'git+https://github.com/boogie-org/boogie.git'
execute_boogie.sh
license.txt)
md5sums=('SKIP'
@@ -27,8 +28,7 @@ pkgver() {
build() {
cd "${srcdir}/${pkgname}/"
- wget https://nuget.org/nuget.exe
- mono ./nuget.exe restore Source/Boogie.sln
+ nuget restore Source/Boogie.sln
xbuild Source/Boogie.sln
}