summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgithubaction2020-09-22 07:44:39 +0000
committergithubaction2020-09-22 07:44:39 +0000
commitffad762b2ef0d775326b906d6f18a32b74056518 (patch)
treea1be8eb6164b493b943b14104d376ec1f8edafd9
parent49d9247f22fda1c6c688d9d509a9612330e2aaf4 (diff)
downloadaur-ffad762b2ef0d775326b906d6f18a32b74056518.tar.gz
Update PKGBUILD and .SRCINFO with GitHub Actions
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b8b953d6556..4b0c0e9e3734 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = boogrocha
pkgdesc = A lightweight, easy to use command-line application (bgc) for managing your group room bookings at Chalmers University of Technology
- pkgver = v1.0.21
+ pkgver = v1.0.22
pkgrel = 1
url = https://github.com/sidusio/boogrocha
arch = x86_64
@@ -8,8 +8,8 @@ pkgbase = boogrocha
makedepends = go
provides = bgc
conflicts = bgc
- source = https://github.com/sidusio/boogrocha/archive/v1.0.21.tar.gz
- sha256sums = e017fe0212da76c217146190fe89b40e6a32569ea9d037a6018967bd469998e6
+ source = https://github.com/sidusio/boogrocha/archive/v1.0.22.tar.gz
+ sha256sums = 20f7728c12a5ba033d594a7f1a7a95b6c3e354b11bdcea20911ab7761bb8337d
pkgname = boogrocha
diff --git a/PKGBUILD b/PKGBUILD
index eda426541b58..bedd5fd469fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
#Maintainer: Karl Wikström <boogrocha@sidus.io>
#Maintainer: William Leven <boogrocha@sidus.io>
-_tag=v1.0.21
+# _tag and sha256 is populated by the pipeline
+_tag=v1.0.22
pkgname=boogrocha
pkgver=$_tag
pkgrel=1
@@ -13,7 +14,7 @@ url="https://github.com/sidusio/boogrocha"
license=("GPL3")
makedepends=(go)
source=($url/archive/$_tag.tar.gz)
-sha256sums=('e017fe0212da76c217146190fe89b40e6a32569ea9d037a6018967bd469998e6')
+sha256sums=('20f7728c12a5ba033d594a7f1a7a95b6c3e354b11bdcea20911ab7761bb8337d')
# The name of the root directory of the tar.gz that Github
# automatically creates and which therefore will be extracted
_src="BooGroCha-${pkgver:1}"
@@ -21,6 +22,7 @@ _src="BooGroCha-${pkgver:1}"
build() {
cd $_src
# Build as per Go package guidelines
+ # https://wiki.archlinux.org/index.php/Go_package_guidelines#Flags_and_build_options
go build \
-trimpath \
-buildmode=pie \