summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Knapp2021-08-11 09:56:52 -0700
committerJonathan Knapp2021-08-11 10:06:17 -0700
commit7d9761a143b0e5512d7da13cf3e306833f0d7c5c (patch)
tree650d66160dfcd0adf0ba5bfffd192ca66d1a5e78
parent2b9acea2078bcb30df7fb9284972422a08b2646b (diff)
downloadaur-boohu-git.tar.gz
Added tiles package
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ec5696fd9a7..126bb3d46e30 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,3 +13,5 @@ pkgbase = boohu-git
md5sums = SKIP
pkgname = boohu-git
+
+pkgname = boohu-tk-git
diff --git a/PKGBUILD b/PKGBUILD
index 585dd41a4ea8..2f703e206e87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# URL: https://github.com/anaseto/boohu
# Upstream: https://github.com/anaseto/boohu
-pkgname=('boohu-git')
+pkgname=('boohu-git' 'boohu-tk-git')
pkgver=0.13.0.5.g9103191
pkgrel=1
pkgdesc="Break Out Of Hareka's Underground, a roguelike game."
@@ -23,16 +23,23 @@ pkgver() {
prepare() {
cd "$pkgname"
- go mod init "${url#https://}" # strip https:// from canonical URL
+ # strip https:// from canonical URL
+ go mod init "${url#https://}" || echo 'already modded'
go mod tidy
}
build() {
cd "$pkgname"
go build -o boohu .
+ go build --tags tk -o boohu-tk .
}
-package() {
+package_boohu-git() {
install -Dm 755 "$srcdir/$pkgname/boohu" -t "$pkgdir/usr/bin";
install -Dm 644 "$srcdir/$pkgname/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname"
}
+
+package_boohu-tk-git() {
+ install -Dm 755 "$srcdir/boohu-git/boohu-tk" -t "$pkgdir/usr/bin";
+ install -Dm 644 "$srcdir/boohu-git/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname"
+}