summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-11-04 13:25:04 +0300
committerorhun2020-11-04 13:25:04 +0300
commitd3872c9ed6052f6cae3e127935c6a8839e01bd59 (patch)
tree60e2122a51669146534bad3bd8c4823ae05a5980
downloadaur-d3872c9ed6052f6cae3e127935c6a8839e01bd59.tar.gz
Initial upload: bookmark-bin 0.1.0-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f868f984b3a2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = bookmark-bin
+ pkgdesc = Save URLs from the terminal and open them quickly in the browser
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/Szymongib/bookmark
+ arch = x86_64
+ license = MIT
+ provides = bookmark
+ conflicts = bookmark
+ conflicts = bookmark-git
+ source_x86_64 = bookmark-0.1.0::https://github.com/Szymongib/bookmark/releases/download/v0.1.0/bookmark-linux-amd64
+ source_x86_64 = bookmark-0.1.0-LICENSE::https://github.com/Szymongib/bookmark/raw/v0.1.0/LICENSE
+ source_x86_64 = bookmark-0.1.0-README.md::https://github.com/Szymongib/bookmark/raw/v0.1.0/README.md
+ sha512sums_x86_64 = 332ccdd85a23e4a8fcbd324d9251a44b42e940dd42668da64415d611765305b57dd19f4357ae714e45065b33d5a7377ebbf973949eb61ca03ec52e70df84c5ba
+ sha512sums_x86_64 = 3f2e09ba09ef8567e5f70e20776075f952bcb4fc632c3bbe771287cd442f202b0f6f140df2870775d27d1ce5a513e29f92d9f978d8563ae16b671526a9d3c48f
+ sha512sums_x86_64 = ef77c1169d7fdb13f7afa407bba76110ac1230e845e3c0d73528ccb959bcccb493d2ebb7e24753c5852afd5ad196f59ca426d20346cc67f34eb57debec5160e4
+
+pkgname = bookmark-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e8a0c066983
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
+
+pkgname=bookmark-bin
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Save URLs from the terminal and open them quickly in the browser"
+arch=('x86_64')
+url="https://github.com/Szymongib/bookmark"
+license=('MIT')
+conflicts=("${pkgname%-bin}" "${pkgname%-bin}-git")
+provides=("${pkgname%-bin}")
+source_x86_64=("${pkgname%-bin}-$pkgver::$url/releases/download/v$pkgver/${pkgname%-bin}-linux-amd64"
+ "${pkgname%-bin}-$pkgver-LICENSE::$url/raw/v$pkgver/LICENSE"
+ "${pkgname%-bin}-$pkgver-README.md::$url/raw/v$pkgver/README.md")
+sha512sums_x86_64=('332ccdd85a23e4a8fcbd324d9251a44b42e940dd42668da64415d611765305b57dd19f4357ae714e45065b33d5a7377ebbf973949eb61ca03ec52e70df84c5ba'
+ '3f2e09ba09ef8567e5f70e20776075f952bcb4fc632c3bbe771287cd442f202b0f6f140df2870775d27d1ce5a513e29f92d9f978d8563ae16b671526a9d3c48f'
+ 'ef77c1169d7fdb13f7afa407bba76110ac1230e845e3c0d73528ccb959bcccb493d2ebb7e24753c5852afd5ad196f59ca426d20346cc67f34eb57debec5160e4')
+
+package() {
+ install -Dm 755 "${pkgname%-bin}-$pkgver" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm 644 "${pkgname%-bin}-$pkgver-README.md" "$pkgdir/usr/share/doc/${pkgname%-bin}/README.md"
+ install -Dm 644 "${pkgname%-bin}-$pkgver-LICENSE" "$pkgdir/usr/share/licenses/${pkgname%-bin}/LICENSE"
+}