summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Shark2021-10-24 16:11:29 +0300
committerAndrew Shark2021-10-24 16:11:29 +0300
commit22055ee3f6deb1de4990e8f3665b59a5d6067e1d (patch)
treef1a59b095d83c70924b4128f4ec7cf0d5f95bb97
downloadaur-22055ee3f6deb1de4990e8f3665b59a5d6067e1d.tar.gz
v0.1.1-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD27
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52ccd11a4228
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = bookmarksync-git
+ pkgdesc = sync file picker bookmarks for KDE and GTK
+ pkgver = 0.1.1.r1.g936eec8
+ pkgrel = 1
+ url = https://github.com/jlu5/bookmarksync
+ arch = x86_64
+ license = GPLv3
+ makedepends = git
+ source = git+https://github.com/jlu5/bookmarksync.git
+ sha256sums = SKIP
+
+pkgname = bookmarksync-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b70e7d7923f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Andrew Shark <ashark @ at @ linuxcomp.ru>
+pkgname=bookmarksync-git
+pkgver=0.1.1.r1.g936eec8
+pkgrel=1
+pkgdesc="sync file picker bookmarks for KDE and GTK"
+arch=(x86_64)
+url="https://github.com/jlu5/bookmarksync"
+license=('GPLv3')
+makedepends=(git)
+source=(git+https://github.com/jlu5/bookmarksync.git)
+sha256sums=("SKIP")
+
+build() {
+ cd ${pkgname%-git}/src
+ qmake
+ make -j$(nproc) # Read user's option from makepkg.conf? Example in notepadqq-git.
+}
+
+package() {
+ install -D ${pkgname%-git}/src/bookmarksync "${pkgdir}/usr/bin/bookmarksync"
+ install -D ${pkgname%-git}/bookmarksync.desktop "${pkgdir}/usr/share/applications/bookmarksync.desktop"
+}
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}