summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorthaliarchos2021-01-13 09:28:34 -0500
committerthaliarchos2021-01-13 09:28:34 -0500
commit3d2c8449ebaa91fea0a62fd4c4c8243953eb5f4f (patch)
treed18f9a0c106adc0650c605823d426a99d9eeb259
parent3a05a0e77d528f92e6473e394bf6b92a785cd392 (diff)
downloadaur-3d2c8449ebaa91fea0a62fd4c4c8243953eb5f4f.tar.gz
Update: Removed use_wget.patch
Already accepted in upstream
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--use_wget.patch15
3 files changed, 2 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f74526db0329..f5f45766b906 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bookmenu-git
pkgdesc = Command line interface ebooks browser and downloader for LibGen using the InterPlanetary File System.
- pkgver = r74.d3805d7
+ pkgver = r90.fa6b93e
pkgrel = 1
url = https://github.com/kusky3/bookmenu
arch = any
@@ -11,9 +11,7 @@ pkgbase = bookmenu-git
provides = bookmenu
conflicts = bookmenu
source = git+https://github.com/kusky3/bookmenu
- source = use_wget.patch
md5sums = SKIP
- md5sums = 7aaba52c2b2f95e730813cefb1b84bd9
pkgname = bookmenu-git
diff --git a/PKGBUILD b/PKGBUILD
index 007a1f49acaf..093ed970dfe1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: thaliarchos <thaliarchos at protonmail dot com>
pkgname=bookmenu-git
-pkgver=r76.930a68c
+pkgver=r90.fa6b93e
pkgrel=1
pkgdesc="Command line interface ebooks browser and downloader for LibGen using the InterPlanetary File System."
arch=('any')
@@ -17,12 +17,10 @@ options=()
install=
source=(
'git+https://github.com/kusky3/bookmenu'
- 'use_wget.patch'
)
noextract=()
md5sums=(
'SKIP'
- '7aaba52c2b2f95e730813cefb1b84bd9'
)
pkgver() {
@@ -30,11 +28,6 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "$srcdir/${pkgname%-git}"
- git apply "../use_wget.patch"
-}
-
package() {
cd "$srcdir/${pkgname%-git}"
install -Dm755 "${pkgname%-git}" "${pkgdir}/usr/bin/${pkgname%-git}"
diff --git a/use_wget.patch b/use_wget.patch
deleted file mode 100644
index d186f7c9e04f..000000000000
--- a/use_wget.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/bookmenu b/bookmenu
-old mode 100644
-new mode 100755
-index 16d81eb..11631ae
---- a/bookmenu
-+++ b/bookmenu
-@@ -16,7 +16,7 @@ TEXT="/tmp/bookmenu_text"
-
- command -v chafa >/dev/null || { echo "missing \"chafa\" dependency"; exit 1; }
-
--get_index() { curl -s "${URL1}/${QUERY}/?extension=$FORMAT" > $INDEX; }
-+get_index() { wget -O - -q "${URL1}/${QUERY}/?extension=$FORMAT" > $INDEX; }
- get_list() { grep "data-src" $INDEX | cut -d'"' -f8 | sed '/^\//d' > $LIST; max=$(wc -l $LIST | cut -d' ' -f1); }
- get_title() { grep "text-decoration" $INDEX | cut -d'>' -f2 | tail -n +3 | sed -e "s/...$//" > $TITLE; }
- get_info() { grep 'MB\|KB' $INDEX | cut -d">" -f2 | cut -d"<" -f1 > $INFO; }