summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2021-02-04 12:24:15 +0100
committerJosip Ponjavic2021-02-04 12:24:15 +0100
commit6c36da28f89df5b163cb33c4a5505c5ea88754e4 (patch)
treecb1aabe71a501e86777f79bceaa272e63a8244d7
parentec1de38443adaf7c353fa1d4af89b03300143c45 (diff)
downloadaur-bookworm-git.tar.gz
upgpkg: 1.1.2.r179.g3b1cc9d-1 sync with arch
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD32
-rw-r--r--html2text.patch10
3 files changed, 39 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ae5bd2c6183..de8e64a510b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bookworm-git
pkgdesc = A simple user centric eBook reader which displays multiple eBooks formats uniformly
- pkgver = 1.1.1.r48.g3537e86
+ pkgver = 1.1.2.r179.g3b1cc9d
pkgrel = 1
url = https://babluboy.github.io/bookworm
arch = x86_64
@@ -8,15 +8,20 @@ pkgbase = bookworm-git
makedepends = git
makedepends = meson
makedepends = vala
- depends = libgranite.so
+ makedepends = ninja
+ depends = granite
depends = poppler-glib
+ depends = python
depends = unarchiver
depends = unzip
depends = webkit2gtk
+ depends = python-html2text
provides = bookworm
conflicts = bookworm
source = bookworm::git+https://github.com/babluboy/bookworm.git
+ source = html2text.patch
sha256sums = SKIP
+ sha256sums = a90f0753d54aa8f3b72816494928f8e9b72bf26fccd477adfa495e9e2c93dc42
pkgname = bookworm-git
diff --git a/PKGBUILD b/PKGBUILD
index 4f035026dfd8..0ff4af4522fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,41 @@
# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
pkgname=bookworm-git
-pkgver=1.1.1.r48.g3537e86
+pkgver=1.1.2.r179.g3b1cc9d
pkgrel=1
pkgdesc='A simple user centric eBook reader which displays multiple eBooks formats uniformly'
-arch=('x86_64')
+arch=(x86_64)
url='https://babluboy.github.io/bookworm'
-license=('GPL3')
-depends=('libgranite.so' 'poppler-glib' 'unarchiver' 'unzip' 'webkit2gtk')
-makedepends=('git' 'meson' 'vala')
+license=(GPL3)
+depends=(granite poppler-glib python unarchiver unzip webkit2gtk python-html2text)
+makedepends=(git meson vala ninja)
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
-source=("${pkgname%-*}::git+https://github.com/babluboy/bookworm.git")
-sha256sums=('SKIP')
+source=("${pkgname%-*}::git+https://github.com/babluboy/bookworm.git"
+ 'html2text.patch')
+sha256sums=('SKIP'
+ 'a90f0753d54aa8f3b72816494928f8e9b72bf26fccd477adfa495e9e2c93dc42')
pkgver() {
cd "${pkgname%-*}"
git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
+prepare() {
+ cd "${pkgname%-*}"
+ patch -p1 < ../html2text.patch
+ mkdir build
+}
+
build() {
- arch-meson ${pkgname%-*} build -Db_pie=false
- ninja -C build
+ cd "${pkgname%-*}"
+ meson build --prefix=/usr
+ cd build
+ ninja
}
package() {
- DESTDIR="$pkgdir" ninja -C build install
+ cd "${pkgname%-*}"/build
+ DESTDIR="$pkgdir" ninja install
+ install -m644 -D ../COPYING "$pkgdir"/usr/share/licenses/bookworm/COPYING
}
diff --git a/html2text.patch b/html2text.patch
new file mode 100644
index 000000000000..6d1c836d5507
--- /dev/null
+++ b/html2text.patch
@@ -0,0 +1,10 @@
+diff --git a/data/scripts/com.github.babluboy.bookworm.search.sh b/data/scripts/com.github.babluboy.bookworm.search.sh
+index 058f561..8dbd7ff 100644
+--- a/data/scripts/com.github.babluboy.bookworm.search.sh
++++ b/data/scripts/com.github.babluboy.bookworm.search.sh
+@@ -5,4 +5,4 @@
+
+ HTML_CONTENT_TO_BE_SEARCHED=$1
+ USER_SEARCH_TEXT=$2
+-html2text -utf8 "$HTML_CONTENT_TO_BE_SEARCHED" | tr '\n' ' ' | grep -E -o -i ".{0,50}$USER_SEARCH_TEXT.{0,50}"
++html2text "$HTML_CONTENT_TO_BE_SEARCHED" | tr '\n' ' ' | grep -E -o -i ".{0,50}$USER_SEARCH_TEXT.{0,50}"