summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAzat Abdullin2020-01-10 13:02:02 +0300
committerAzat Abdullin2020-01-10 13:02:02 +0300
commit95c32c512ee8f352e7135ac2b57067e7800b9fa6 (patch)
tree92df540aa60029f178792334d2295bee6cc154bf
parent30cf0b7b3496ec1bcf093d1ca3148c268dad190d (diff)
downloadaur-95c32c512ee8f352e7135ac2b57067e7800b9fa6.tar.gz
v3.1.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD32
2 files changed, 26 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6d0a9ad9ac4..fc97072d76d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,19 @@
pkgbase = boolector
pkgdesc = Boolector is an efficient SMT solver for the quantifier-free theory of bit-vectors in combination with the quantifier-free extensional theory of arrays.
- pkgver = 3.0.0
+ pkgver = 3.1.0
pkgrel = 1
url = http://boolector.github.io/
arch = i686
arch = x86_64
license = MIT
- source = https://github.com/Boolector/boolector/archive/3.0.0.tar.gz
- md5sums = b0d6755dd8a9706adac0d5d94f38abb9
+ makedepends = make
+ makedepends = cmake
+ makedepends = git
+ depends = btor2tools-unstable-git
+ conflicts = boolector-git
+ source = https://github.com/Boolector/boolector/archive/3.1.0.tar.gz
+ sha256sums = SKIP
+ sha512sums = SKIP
pkgname = boolector
diff --git a/PKGBUILD b/PKGBUILD
index c86567f56193..e6e6f7a7f2c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,31 @@
# Maintainer: Marat Akhin <Marat.Akhin@gmail.com>
+# Comaintainer: Azat Abdullin <abdullin@kspt.icc.spbstu.ru>
pkgname=boolector
-pkgver=3.0.0
+pkgver=3.1.0
pkgrel=1
pkgdesc="Boolector is an efficient SMT solver for the quantifier-free theory of bit-vectors in combination with the quantifier-free extensional theory of arrays."
arch=('i686' 'x86_64')
url="http://boolector.github.io/"
license=('MIT')
-makedepends=()
-conflicts=()
+depends=("btor2tools-unstable-git")
+makedepends=("make" "cmake" "git")
+conflicts=("boolector-git")
-source=("https://github.com/Boolector/boolector/archive/3.0.0.tar.gz")
-md5sums=('b0d6755dd8a9706adac0d5d94f38abb9')
+source=("https://github.com/Boolector/boolector/archive/3.1.0.tar.gz")
+sha256sums=('SKIP')
+sha512sums=('SKIP')
build() {
- cd "$srcdir/boolector-3.0.0"
+ cd "$srcdir/boolector-3.1.0"
- # Download and build Lingeling
+ # Setup lingeling
./contrib/setup-lingeling.sh
- # Download and build BTOR2Tools
- CFLAGS="" ./contrib/setup-btor2tools.sh
-
# Build Boolector
- CFLAGS="" ./configure.sh && cd build && make
+ CFLAGS="" ./configure.sh --shared
+ cd build
+ make
}
package() {
@@ -31,12 +33,12 @@ package() {
mkdir -p "$pkgdir/usr/lib/"
mkdir -p "$pkgdir/usr/include/boolector"
- cd "$srcdir/boolector-3.0.0/src"
+ cd "$srcdir/boolector-3.1.0/src"
find . -name "*.h" -exec install -D -m644 {} "$pkgdir/usr/include/boolector/{}" \;
- cd "$srcdir/boolector-3.0.0"
- find . -name "*.a" -exec install -m755 {} "$pkgdir/usr/lib/" \;
+ cd "$srcdir/boolector-3.1.0"
+ find . -name "*.so" -exec install -m755 {} "$pkgdir/usr/lib/" \;
- cd "$srcdir/boolector-3.0.0/build/bin"
+ cd "$srcdir/boolector-3.1.0/build/bin"
find . -name "b*" -exec install -D -m755 {} "$pkgdir/usr/bin/{}" \;
}