summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2021-01-18 16:30:42 +0100
committerChristopher Arndt2021-01-18 16:30:42 +0100
commite5a74c18c68f32e96a87237f1dec7e4af3f1d7e3 (patch)
treef5e072f26c958f1975b78a6244e51f773549487d
downloadaur-e5a74c18c68f32e96a87237f1dec7e4af3f1d7e3.tar.gz
Add new VCS package 'boops.lv2-git'
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD47
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b3b499c9451d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = boops.lv2-git
+ pkgdesc = A glitch effect sequencer LV2 plugin (git version)
+ pkgver = 1.2.4.r0.gbdb4de4
+ pkgrel = 1
+ url = https://github.com/sjaehn/BOops
+ arch = x86_64
+ groups = lv2-plugins
+ groups = pro-audio
+ license = GPL3
+ checkdepends = lv2lint
+ makedepends = git
+ makedepends = lv2
+ depends = cairo
+ depends = gcc-libs
+ depends = glibc
+ depends = libsndfile
+ depends = libx11
+ provides = boops
+ provides = boops=1.2.4
+ provides = boops.lv2
+ provides = boops.lv2=1.2.4
+ conflicts = boops
+ conflicts = boops.lv2
+ source = boops.lv2::git+https://github.com/sjaehn/BOops
+ md5sums = SKIP
+
+pkgname = boops.lv2-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..058837a5bbf8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+boops.lv2/
+boops.lv2-git-*.pkg.tar.xz
+boops.lv2-git-*.pkg.tar.zst
+pkg/
+src/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5bc555edbfed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+_name="BOops"
+_pkgname="${_name,,}.lv2"
+_plugin_uri="https://www.jahnichen.de/plugins/lv2/${_name}"
+pkgname="${_pkgname}-git"
+pkgdesc="A glitch effect sequencer LV2 plugin (git version)"
+pkgver=1.2.4.r0.gbdb4de4
+pkgrel=1
+arch=('x86_64')
+url="https://github.com/sjaehn/${_name}"
+license=('GPL3')
+groups=('lv2-plugins' 'pro-audio')
+depends=('cairo' 'gcc-libs' 'glibc' 'libsndfile' 'libx11')
+makedepends=('git' 'lv2')
+checkdepends=('lv2lint')
+provides=("${_name,,}" "${_name,,}=${pkgver//.r*/}" "${_pkgname}" "${_pkgname}=${pkgver//.r*/}")
+conflicts=("${_name,,}" "${_pkgname}")
+source=("${_pkgname}::git+https://github.com/sjaehn/${_name}")
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd "${srcdir}/$_pkgname"
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "${srcdir}/$_pkgname"
+ make
+}
+
+check() {
+ cd "${srcdir}/${_pkgname}"
+ lv2lint -Mpack -I "${_name}.lv2/" "${_plugin_uri}"
+}
+
+package() {
+ cd "$_pkgname"
+ make PREFIX="/usr" DESTDIR="$pkgdir/" install
+ install -vDm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ # Remove misplaced license file
+ find "${pkgdir}/usr/lib/lv2/${_name}.lv2" -type f -iname "*LICENSE*" -delete
+}