summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames P. Harvey2019-04-27 04:18:57 -0400
committerJames P. Harvey2019-04-27 04:53:22 -0400
commit92ce35cbf77f7d7787b265d8e4a0e172aafd7bce (patch)
tree7f0a04e87a3446a6be2d5ecae009ca6555b90256
downloadaur-92ce35cbf77f7d7787b265d8e4a0e172aafd7bce.tar.gz
Initial commit, v1.1.0.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..92db4d7b1406
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = boost-di
+ pkgdesc = Boost (experimental) c++14 dependency injection library
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/boost-experimental/di
+ arch = any
+ license = Boost
+ makedepends = cmake
+ source = boost-di.tar.gz::https://github.com/boost-experimental/di/archive/v1.1.0.tar.gz
+ sha256sums = 2bb52ed621c36e4e301ed7fbe4197980e9110bd4afc4208841637ce112c0d443
+
+pkgname = boost-di
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc9afd32929e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: James P. Harvey <jamespharvey20 at gmail dot com>
+
+pkgname=boost-di
+_pkgname=di
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Boost (experimental) c++14 dependency injection library"
+arch=('any')
+url="https://github.com/boost-experimental/${_pkgname}"
+license=('Boost')
+makedepends=('cmake')
+source=("${pkgname}.tar.gz::https://github.com/boost-experimental/${_pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('2bb52ed621c36e4e301ed7fbe4197980e9110bd4afc4208841637ce112c0d443')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ cmake .
+ make
+}
+
+check() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ # let user know this test isn't hung, because it will take around a minute even though tons of prior tests were nearly instant
+ sleep 3 && echo && echo "*** test.ft_di_errors will take at least a minute ***" &
+ ctest
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}/include/boost"
+ install -Dm644 di.hpp "${pkgdir}/usr/include/${pkgname}/di.hpp"
+ cp -r di "${pkgdir}/usr/include/${pkgname}"
+}