summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbionade242020-12-09 22:35:01 +0100
committerbionade242020-12-09 22:35:01 +0100
commit0ef5673e92f6d2afce12d7bec9bfad5ca4fad007 (patch)
tree7ea5507cb902399d8b717c369fb44cee2ad517f7
parentd1081b2c31b6fe8a68d11219d58d16829cd6b8a2 (diff)
downloadaur-0ef5673e92f6d2afce12d7bec9bfad5ca4fad007.tar.gz
Remove Python2 support, upgrade Py3 to 3.9 and fix arch array
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD51
2 files changed, 13 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95dacbf7c250..09c69868c5d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = boost1.69
pkgver = 1.69.0
- pkgrel = 4
+ pkgrel = 5
url = https://www.boost.org/
+ arch = i686
arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ arch = armv6h
license = custom
makedepends = icu
makedepends = python
- makedepends = python2
makedepends = python-numpy
- makedepends = python2-numpy
makedepends = bzip2
makedepends = zlib
makedepends = openmpi
@@ -27,7 +29,6 @@ pkgname = boost1.69
pkgdesc = Free peer-reviewed portable C++ source libraries - development headers
depends = boost1.69-libs=1.69.0
optdepends = python: for python bindings
- optdepends = python2: for python2 bindings
conflicts = boost
options = staticlibs
diff --git a/PKGBUILD b/PKGBUILD
index e2675926ca88..646abc18dee9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer:
+# Maintainer: Oskar Roesler <oskar@oskar-roesler.de>
# Contributor: Evangelos Foutras <evangelos@foutrelis.com>
# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
@@ -14,11 +14,11 @@ pkgbase=boost1.69
pkgname=('boost1.69-libs' 'boost1.69')
pkgver=1.69.0
_boostver=${pkgver//./_}
-pkgrel=4
+pkgrel=5
url='https://www.boost.org/'
-arch=('x86_64')
+arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
license=('custom')
-makedepends=('icu' 'python' 'python2' 'python-numpy' 'python2-numpy' 'bzip2' 'zlib' 'openmpi')
+makedepends=('icu' 'python' 'python-numpy' 'bzip2' 'zlib' 'openmpi')
source=(https://downloads.sourceforge.net/project/boost/boost/${pkgver}/boost_${_boostver}.tar.bz2)
sha256sums=('8f32d4617390d1c2d16f26a27ab60d97807b35440d45891fa340fc2648b04406')
@@ -32,7 +32,7 @@ build() {
cd boost_${_boostver}
- ./bootstrap.sh --with-toolset=gcc --with-icu --with-python=/usr/bin/python2
+ ./bootstrap.sh --with-toolset=gcc --with-icu --with-python=/usr/bin/python3
_bindir="bin.linuxx86"
[[ "${CARCH}" = "x86_64" ]] && _bindir="bin.linuxx86_64"
@@ -45,35 +45,6 @@ build() {
install -dm755 "${_stagedir}"/share/boostbook
cp -a tools/boostbook/{xsl,dtd} "${_stagedir}"/share/boostbook/
- # default "minimal" install: "release link=shared,static
- # runtime-link=shared threading=single,multi"
- # --layout=tagged will add the "-mt" suffix for multithreaded libraries
- # and installs includes in /usr/include/boost.
- # --layout=system no longer adds the -mt suffix for multi-threaded libs.
- # install to ${_stagedir} in preparation for split packaging
- "${_stagedir}"/bin/b2 \
- variant=release \
- debug-symbols=off \
- threading=multi \
- runtime-link=shared \
- link=shared,static \
- toolset=gcc \
- python=2.7 \
- cflags="${CPPFLAGS} ${CFLAGS} -fPIC -O3" \
- cxxflags="${CPPFLAGS} ${CXXFLAGS} -std=c++14 -fPIC -O3" \
- linkflags="${LDFLAGS}" \
- --layout=system \
- ${JOBS} \
- \
- --prefix="${_stagedir}" \
- install
-
- # because b2 in boost 1.62.0 doesn't seem to respect python parameter, we
- # need another run for liboost_python3.so
-
- ./bootstrap.sh --with-toolset=gcc --with-icu --with-python=/usr/bin/python3 \
- --with-libraries=python
-
"${_stagedir}"/bin/b2 clean
"${_stagedir}"/bin/b2 \
variant=release \
@@ -82,15 +53,14 @@ build() {
runtime-link=shared \
link=shared,static \
toolset=gcc \
- python=3.8 \
+ python=3.9 \
cflags="${CPPFLAGS} ${CFLAGS} -fPIC -O3" \
cxxflags="${CPPFLAGS} ${CXXFLAGS} -std=c++14 -fPIC -O3" \
linkflags="${LDFLAGS}" \
--layout=system \
${JOBS} \
\
- --prefix="${_stagedir}/python3" \
- --with-python \
+ --prefix="${_stagedir}" \
install
}
@@ -98,8 +68,7 @@ package_boost1.69() {
pkgdesc='Free peer-reviewed portable C++ source libraries - development headers'
depends=("boost1.69-libs=${pkgver}")
conflicts=('boost')
- optdepends=('python: for python bindings'
- 'python2: for python2 bindings')
+ optdepends=('python: for python bindings')
options=('staticlibs')
install -dm755 "${pkgdir}"/usr
@@ -112,9 +81,6 @@ package_boost1.69() {
install -Dm644 "${srcdir}/"boost_${_boostver}/LICENSE_1_0.txt \
"${pkgdir}"/usr/share/licenses/boost1.69/LICENSE_1_0.txt
- install -Dm644 "${_stagedir}"/python3/lib/libboost_*.a \
- "${pkgdir}"/usr/lib/
-
ln -s /usr/bin/b2 "$pkgdir"/usr/bin/bjam
}
@@ -126,7 +92,6 @@ package_boost1.69-libs() {
install -dm755 "${pkgdir}"/usr
cp -a "${_stagedir}"/lib "${pkgdir}"/usr
- cp -a "${_stagedir}"/python3/lib/libboost_* "${pkgdir}"/usr/lib
rm "${pkgdir}"/usr/lib/*.a
# remove library symlinks shipped in boost1.69 / conflicting with boost-libs