summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoregnappahz2023-08-08 01:41:48 +0200
committeregnappahz2023-08-08 01:41:48 +0200
commit2f2d6fccd0587d2f0e2957d220b421f554bb3667 (patch)
treed7f7716650257e9e72427f9be7703b307756c979
parent056a7816a6f734d681a79e6f9daff0b2cbaee07c (diff)
downloadaur-2f2d6fccd0587d2f0e2957d220b421f554bb3667.tar.gz
force old python10 to bypass deprecated Py_TYPE call
Signed-off-by: egnappahz <egnappah@gmail.com>
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 110ead8bf082..630f4e55ff24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc='Free peer-reviewed portable C++ source libraries'
url='https://www.boost.org/'
arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
license=('custom')
-makedepends=('icu' 'python' 'python-numpy' 'bzip2' 'zlib' 'openmpi' 'zstd' 'findutils')
+makedepends=('icu' 'python310' 'python-numpy' 'bzip2' 'zlib' 'openmpi' 'zstd' 'findutils')
source=(https://boostorg.jfrog.io/artifactory/main/release/${pkgver}/source/boost_${_boostver}.tar.bz2)
sha256sums=('8f32d4617390d1c2d16f26a27ab60d97807b35440d45891fa340fc2648b04406')
@@ -26,7 +26,7 @@ build() {
./bootstrap.sh \
--with-toolset=gcc \
--with-icu \
- --with-python=/usr/bin/python3 \
+ --with-python=/usr/bin/python3.10 \
_bindir="bin.linuxx86"
[[ "${CARCH}" = "x86_64" ]] && _bindir="bin.linuxx86_64"